0
$\begingroup$

Why there is no difference even though denoise is on? Am I doing something wrong? The only difference (very minor), I can see is on the reflection of glass at bottom. Also, I don't see it as a good quality render, any suggestion to improve are welcomed. Render Settings are: GPU ENabled Tiles 256 x 256 Sampling: 250 Denoising: Open Image

The first image is with denoising on. enter image description here

This image is with denoise off: Denoise off in render However, when I see viewport with denoising off, I see much noise! viewport image with denoise off

$\endgroup$
2
  • 1
    $\begingroup$ In 2.9 versions denoising is enabled by default... I'd suggest share your settings and version of blender. $\endgroup$
    – brockmann
    Nov 11 '20 at 9:06
  • $\begingroup$ I am using 2.9 and I was able to check and uncheck denoising too. I shared most of the settings. Resolution was 960*1020 $\endgroup$
    – Jehan
    Nov 11 '20 at 10:45
4
$\begingroup$

Let me give you a subtle hint of one possibility why this might happen:

enter image description here

What you may have noticed in the picture is that there are different sampling settings for the render and the viewport.

...but what could be the reason for having the same result with "denoising"on and off?

This might be when you take a clean image rendered with enough samples for it not to have much noise and try to denoise it. The difference is minimal in that case because the denoiser does not have much noise to remove. In your specific case the difference is there and I would not even call it that small. Let's actually look for the difference in the images you have provided for a minute:

enter image description here

$\endgroup$
2
  • $\begingroup$ but what could be the reason for having the same result with "denoising"on and off? Yes, for the viewport thing you are right. I tested :) $\endgroup$
    – Jehan
    Nov 11 '20 at 10:46
  • 1
    $\begingroup$ There is a difference. See the updated answer with a gif. $\endgroup$ Nov 11 '20 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.