1
$\begingroup$

Trying to hand paint a skybox. So im sitting inside a cube, all faces flipped towards me and i'm trying to paint my cubic skybox viewing from the center of the scene. Unfortunately my strokes only get registered by the face that i'm looking at more or less directly. this keeps me from painting in the corners of the cube, doing continuous strokes from one face to another.

From outside the cube it seems to work fine (provided i flip the faces so the normals point outside of the cube again) i can even paint at extreme angles.

ANY settings of the normal falloff option in the properties panel under tool->bushsettings->falloff didn't solve the issue (i tried turning it off, 0 deg, 45 deg, 90 deg)

is there a way to tell blender just not to worry about my view angle towards any given face and just paint my darn stroke?

Thanks in advance

enter image description here

$\endgroup$
0
$\begingroup$

Perhaps try turning off Occlude in the Options panel in the tool settingsenter image description here

$\endgroup$
2
  • $\begingroup$ Hi, thanks for answering Unfortunately unchecking occlude doesn't solve the issue $\endgroup$
    – draw_bot
    Nov 11 '20 at 16:49
  • $\begingroup$ No real reason then for the issue to be present, unchecking Occlude means you paint through all mesh in the way, all the way through your model. Maybe make a simple file that replicates the problem and post up a bug report. $\endgroup$ Nov 11 '20 at 17:05
0
$\begingroup$

Workaround proposed by blender devs themselves: subdivide the cube in order to create several faces, that lets you paint continuous strokes! keeping the UV Smooth option under the advanced section of the subsurf modifier set to sharp will yield the expected result. Yeyy

$\endgroup$
1
  • $\begingroup$ correction: the texture distortion that this method yields doesnt match the needed distortion to apply the textures to a standard cubic skybox after all. couldnt wrap my head around it yet. i now started distorting the elements of the skybox by hand in ps where necessary.. : / $\endgroup$
    – draw_bot
    Nov 23 '20 at 22:45
0
$\begingroup$

This is what worked for me. Uncheck 'normal' from options when in texture paint mode from tool bar. I'm using blender 2.77

tool bar

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.