13
$\begingroup$

Render Border,

enter image description here

is a great little function for reducing render time while experimenting, but what does the 'Render Border' check box in the Properties >View panel do - apart from turning off the red border when un-checked? (there is no Manual reference to this)

enter image description here

Also, after setting a Render Border, in the Tool Shelf >Set Render Border panel, there is a 'Camera Only' check box:

enter image description here

I have tried many different combinations of these with renders, and the result is… confusion! Can someone please clarify this for me?

$\endgroup$
  • $\begingroup$ wait, how did you get those X min, X max properties ? $\endgroup$ – ChameleonScales Feb 7 '17 at 20:50
8
$\begingroup$

Expanding on sambler and Aldrik's answers,

Enabling the Border setting in Render settings > Dimensions enables border for the rendered image and sets the camera bounds as the Camera Border.

enter image description here

As you can see, in the Viewport render with Border enabled, only the part of the scene visible to the camera is rendered:

enter image description here

With Border disabled, everything is rendered:

enter image description here

Viewport border:

Ctrl+B (or View > Render border) sets region in the 3D view that will be rendered when the Viewport shading is set to Rendered (this can be toggled in 3D view > Properties Panel (N) > Render Border

enter image description here

(Useful for making the part of the scene you want to see converge faster by not rendering other parts)

As mentioned by sambler, the Camera Only setting does not seem to make any difference (bug?)

Rendered Border:

Using Ctrl+B or Shift+B in the Camera view will define a region in the camera that will be rendered while the rest of the camera will not (if Render settings > Border is not already enabled, doing this will enable it)

enter image description hereenter image description here

As you can see, the rendered image only rendered the border selection and left the rest as black (or transparent, if you have your render settings set to RGBA in a format that supports transparency)

The Crop option enter image description here crops the black part off automatically:

enter image description here

(Note that disabling the Border setting in Render Settings > Dimensions or in 3D view > Properties > View will not erase the border selections)
Pressing Ctrl+Alt+B will clear all the borders and disable the border setting in Render settings and the Properties panel.

$\endgroup$
  • $\begingroup$ This answer is the most complete one, but I think my answer (Set Viewport Shading to Rendered, if you don't, then Render Border, and the Render Border check box don't function properly) should be added, to prevent others from having the same problem. $\endgroup$ – SteveW Jul 29 '13 at 2:33
  • $\begingroup$ @SteveW I'm not sure what you mean by they won't function properly, (As far as i can tell, they do what they ought to do when nothing is rendering) If you mean that they will have no effect, I added a mention about that in my answer. $\endgroup$ – gandalf3 Jul 29 '13 at 2:51
  • $\begingroup$ What I mean is this: If, for example, your Viewport setting is 'Solid' and you are not in camera view, you can draw a Render Border - but it does absolutely nothing! There is nothing to tell you 'you must be in Rendered Viewport Rendering' for it to work. On the other hand, if you change to Camera View it does work when you Render (F12). This was the whole reason for my question in the first place! : / $\endgroup$ – SteveW Jul 29 '13 at 3:35
2
$\begingroup$

The border render defines a rectangular area that confines the rendered result.

You have two border settings available.

1) The first border is applied to the camera view and final render. The border option in the render settings enables/disables the effect of this setting.

2) The other border setting only applies to the viewport render whether you are viewing from left, right, top, user defined etc. This border does not affect the render result and is not visible when you switch to camera view in the viewport.

There is an operator to 'Clear Render Border' with a CtrlAltB shortcut that doesn't appear to have a menu entry. This operator will clear (not just disable) either defined border depending on the current viewport.

I believe the Camera only option you see in the operator panel is intended to define the clipping border is to be applied as 1 above. I don't see that option making a difference currently.

$\endgroup$
1
$\begingroup$

Properties shelf Render Border setting

With the introduction of the Rendered Viewport Shading, render border can be used to limit the rendered region of the 3D View. The setting in the Properties shelf toggles this feature.

3D View using Rendered Viewport Shading with render border 3D View using Rendered Viewport Shading without render border

Camera Only check box

This creates a render border only if in camera view. Enabling it in the Tool Self does not undo the initial boarder creation. It seems to exist only so the Shift+B shortcut can function differently depending on the view.

$\endgroup$
  • $\begingroup$ A good explanation but I fail to see how this answers OP's question(s). $\endgroup$ – iKlsR Jul 28 '13 at 5:19
  • 2
    $\begingroup$ Please read the question before answering. ;) $\endgroup$ – SteveW Jul 28 '13 at 5:23
  • $\begingroup$ I tested the shift+B shortcut, and it does draw a border in camera view (not in normal view though) but so does ctrl+B.. what is the point of having two shortcuts that do the same thing? $\endgroup$ – gandalf3 Jul 29 '13 at 18:04
  • $\begingroup$ @gandalf3 Shift+B is the original legacy shortcut for render border. $\endgroup$ – Aldrik Jul 29 '13 at 18:35
0
$\begingroup$

From my point of view, this is the answer:

Set Viewport Shading to Rendered, if you don't, then Render Border, and the Render Border check box don't function properly, and also, the Camera Only check box doesn't work at all.

This has been an unintentional trick question (due to my ignorance). I had no idea that the Viewport Shading > Rendered worked so well (or even existed for that matter)! I have used the Solid setting for so long now, ignoring the other settings.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.