0
$\begingroup$

How do I create a particle system from an imported stl model and use that to fill the shell of another model? As you can see below, I want to fill the model to the right. There are two issues I am having. 1) The body is currently emitting the mini figurines rather that the internally contained collisions I was expecting. 2) A displaced modifier was applied to prevent the particles from moving beyond the skin, but if I could just set the collision boundary to the skin itself, that would be best. I read that applied modifiers are permanent, so I may need to redo this particle system on the original stl. Thank you!

enter image description here

enter image description here

(11/9/20) Tried Vertex paint mode and selecting the body under the Vertex Group --> Desnity, but it still had the same effect. I think the problem also is that internal face or area is not the source of the emitter. However, I found a tutorial here that shows how to fill a container by funneling the smaller objects via implemented physics engine. Will see if that works!

enter image description here

$\endgroup$

1 Answer 1

0
$\begingroup$

I believe what you're looking for is the 'hair' particles system, if you want another object to cover the main object. When you add a particle system to an object, one of the first options should be to choose from Emission and Hair, switch it to hair. I'd recommend watching some tutorials for the same. If this is not what you were looking for, please reply.

$\endgroup$
4
  • $\begingroup$ I actually wanted to fill the bottom half shell of the sculpture with the mini figurines instead of having them covering the object. Thank you for your feedback though! $\endgroup$
    – user109540
    Nov 8, 2020 at 17:54
  • $\begingroup$ You can vertex-painting for that. Go into vertex painting mode, select the part which you think should have the mini-figures, go back to your particle system, scroll down until you see 'Vertex Groups' and for density, select the one that you just painted on. $\endgroup$ Nov 9, 2020 at 14:56
  • $\begingroup$ I tried the vertex paint mode and selected the body, but the particles are still being emitted from the skin of th sculpture as shown above. You may check to see if it was set properly above. Thanks! $\endgroup$
    – user109540
    Nov 9, 2020 at 18:19
  • $\begingroup$ I can't tell based on the image, again, make sure you have it set to Hari and not Emission. And make sure that the right vertex group is selected. I'd love to help you out, can I contact you via Discord? $\endgroup$ Nov 10, 2020 at 4:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .