1
$\begingroup$

I have added some holes in my model using *Boolean` modifier (it is applied) and I have some problems with the Sub Surface modifier., it seems like the faces are not connecting.

I have made sure there are no overlapping vertices and every face has 4 vertices. (I am still pretty new to Blender)

Before the Sub Surface modifier. mesh before sub surface modifier

This is after. after sub surface modifier

It makes these rounded edges on the faces in the corners.

close up

$\endgroup$
6
0
$\begingroup$

As moonboots suggested, the Edge Split modifier is the culprit here. It literally turns every edge into 2 edges creating disconnected faces which messes with subsurf. Edge Split Modifier Doco You can test this by turning "Sharp Edges" off and reducing the "Edge Angle" value down to 0. You will notice that every face becomes rounded as though every face is disconnected. (Cool effect though!) Edge Angle at 0

For what you are trying to achieve, using Crease is a much better option. Delete the Edge Split modifier, select the edges you wish the subsurf modifier not to effect and hit Shift-E to add a crease to those edges. It is a bit of an art knowing which edges to apply Crease to but you will learn it as you go. The crease value can also be found in the N-Panel under "Item"

Mean Crease

With Crease

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.