0
$\begingroup$

I'm trying to extrude using the extrude faces along normal, and also trying make a simple E, then S + shift Z to scale on X and Y axis, but its not extruding inwards uniformly. on the cube mesh, its working, but on the more complex model its looking incorrect.

enter image description here

$\endgroup$
7
  • 2
    $\begingroup$ Make sure you have scale applied (Ctrl+A > scale) in object mode. Also, make sure you normals are all facing out by selecting the whole mesh in edit mode, then mesh > normals > recalculate outside. If none of that works, make sure you have no dupes by doing a merge by distance. $\endgroup$ Commented Nov 6, 2020 at 4:37
  • $\begingroup$ Hi Christopher. I tried everything you mentioned, and still get the awkward result. I also noticed when extruding on a mesh which is not scaled inwards, the result is better, but I have noticed that some of the lines tend to curve and others are straight although its just a cube mesh. ibb.co/pbScpHT ibb.co/Z6VLftv $\endgroup$ Commented Nov 6, 2020 at 5:23
  • $\begingroup$ ibb.co/S7xMkS4 $\endgroup$ Commented Nov 7, 2020 at 7:35
  • $\begingroup$ Yeah, that's strange. There must be something else going on, but I don't think I can explain it, I'm afraid. $\endgroup$ Commented Nov 7, 2020 at 8:59
  • 1
    $\begingroup$ in addition to christopher's solution , try to hit "a" and "m" and select "by distance" before try to extrude , also you migh have extra faces inside your geometry , which in resault of wrong modeling , try to delete them by hitting "alt + z" and selecting those faces $\endgroup$ Commented Sep 10, 2021 at 19:46

0

You must log in to answer this question.

Browse other questions tagged .