0
$\begingroup$

Long story, bear with me.

  • I'm doing a research project involving ct scans and skull measurements.
  • I create models of skulls (called segmentations) in a software called 3DSlicer and import them into Blender as .stl's
  • I understand that .stl's don't have inherent "units", and so I understand that when I first measure a skull I import, I might get something like this:

enter image description here

  • A- how could I fix that? I.e. get it to say 21 cm instead? Is there a way to set the units of an object I import? Do I need to set the global scale or units first or something?
  • I bet with enough googling I could probably figure out that step (although I have tried), but I still think this next step would be odd:
  • I have been drawing a curve, turning that into a "surface" and turning that into a mesh (could I go straight to mesh?) in order to get the surface area of a hole in the skull: enter image description here enter image description here
  • And am I crazy, or does that seem like wayyyy too big of a number? Even assuming that I need to change the initial units when i import, if an even bigger hole there would be the 88x66 meters I drew, that would be 5808 meters, which would be 580800 centimeters cubed, which is still 25x smaller than what it is measuring for me. (Thats the 3d print toolbox addon). What gives? Is that surface area giving me both sides of the mesh? Can it being wavy affect it THAT much? Is there a better way to measure surface area of that hole?

Our ultimate goal for that step (if it helps spur any ideas) is to track the hole size across several scans in time and see if it gets bigger

So to summarize: How do I set the units to be more realistic upon import, and how could I get a more realistic surface area measurement for the hole in the skull?

$\endgroup$
  • $\begingroup$ Is the mesh scaled (property panel in object mode)? $\endgroup$ – lemon Nov 5 '20 at 19:17
  • $\begingroup$ Says 1.0 for all the different scale options. $\endgroup$ – Joe Crozier Nov 5 '20 at 19:56
  • 1
    $\begingroup$ To change the scale of the .stl file on import: Top right hand corner of the Import .stl window use the little gear icon to open the Transform options and there you can change the Scale value to 0.001 or whatever. To show measurements in cm: from the Properties Editor > Scene Properties > Units > change Length from the default Meters to Centimeters. $\endgroup$ – 3fingeredfrog Nov 5 '20 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.