15
$\begingroup$

I have a few video strips with audio that I want to import to the Video Sequence Editor (VSE), but they are of different fps... examples are 23.97, 24, 29.97 and 30 fps. Let's say I want to select an fps of 30 in my project, is there a way to import the video clips and converting them to 30 fps?

Making every 4 frames into 5 frames, for example for 24 to 30 fps conversion. I am not sure what it's terminology in the video editing area.

$\endgroup$
  • $\begingroup$ It has been my experience today that if you add a 1FPS video and then a 30FPS video both lasting 1 minute that you'll end up with 1 channel that plays 30 times faster then the other. If I then set my render speed to 1fps, then the 30fps channel lasts for 30 minutes. $\endgroup$ – user2867 Mar 21 '14 at 18:44
  • 1
    $\begingroup$ Here you go. This is the work around, super easy. youtube.com/watch?v=3SpVpqsvqwM $\endgroup$ – user29276 Aug 7 '16 at 18:05
5
$\begingroup$

Currently there's no support for motion-compensated frame interpolation. So you will need to run your footage through an external application.

$\endgroup$
11
$\begingroup$

There is actually an effect strip "Speed Control" which can sort of change the fps of a video strip. If converting from 24 to 30 fps, you can set the Multiply Speed to 0.8.

However there isn't any interpolation at all, it's like every 5 frames there are two frames exactly the same, thus creating a not so smooth resulting video.

$\endgroup$
  • 2
    $\begingroup$ I think it's better to use Speed Control, leave the Multiply Speed at 1.0, and make sure "Stretch to input strip length" is checked. Then you adjust the length of the strip and the speed control stretches to match it. $\endgroup$ – Mutant Bob Apr 16 '14 at 19:06
  • $\begingroup$ Mutant Bob's answer did exactly what I needed it to do taking at 23fps video and upscaling it to 30fps. $\endgroup$ – Corey S. Mar 13 '16 at 20:45
1
$\begingroup$

Blender imports video sequences based on the current render settings. An easy way to tell the settings are wrong when importing video is the audio imports with a different length than the video. The audio time gets read in but the video rate is set by the render settings.

Try setting the render frame rate to 23.97 then importing the 23.97fps videos. then change the frame rate to 29.97 and import the 29.97fps videos and so on.

When finished set the desired output frame rate and render the animation.

$\endgroup$
  • 3
    $\begingroup$ Have you actually tried that? Changing the render fps after importing the video does not change the length, but the A/V is obviously out of sync. $\endgroup$ – Alvin Wong Jul 29 '13 at 1:08
  • $\begingroup$ This answered the query that got me here, "Why doesn't my video length match my audio", so thanks ;) $\endgroup$ – pix Oct 9 '15 at 1:17

protected by Community Aug 7 '16 at 21:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.