2
$\begingroup$

Node Set upAMD Ryzen 7 2700 8-core 4.1, 32 GB RAM, RTX 2060 (6GB VRAM)

I have a glass and transparent BSDF set up correctly in Blender, and the texture set to alpha clip, and alpha hashed for shadows. The glass works perfectly in GPU mode but is not showing the image behind it in CPU mode - simply switching from one to the other.

The scene, even with optimisations, is still too large to render on the GPU for my card. Simply switching from GPU to CPU to allow for rendering the image results in the glass/transparnet shader no longer being see-through.

Is this a bug or is there something I have missed?GPU vs CPU Transparent Render

$\endgroup$
15
  • $\begingroup$ Could you share your material setup? $\endgroup$
    – bstnhnsl
    Nov 5 '20 at 14:14
  • $\begingroup$ Yes I could but it's simply a glass shader, and a transparent shader mixed going into the surface. Neither the glass or the Transparent on their own work in CPU mode. They are fine in GPU mode. Why would that be? $\endgroup$ Nov 5 '20 at 18:21
  • $\begingroup$ How do you mix them? What is the difference between the image on the left and the image on the right? If the scene is too large, how do you know it looks fine on the GPU? Would be easier if you’d share the file or give us a little more information. $\endgroup$
    – bstnhnsl
    Nov 5 '20 at 18:36
  • 1
    $\begingroup$ If you could at least add a screenshot of the node setup & material settings, that could go a long way here. No one can answer this question based on just the CPU/GPU tidbit of info, that's not nearly enough detail to figure out what's going wrong here. $\endgroup$
    – emackey
    Nov 8 '20 at 18:00
  • 1
    $\begingroup$ Not really...it is a commercial model and the file size is over 1 Gb. What I will do today is do some tests in a blend file with just basic shapes and textures. If it doesn't work there I will share that as well. $\endgroup$ Nov 10 '20 at 8:33
0
$\begingroup$

This may or may not help your problem but you shouldn't use glass and transparent shader mix, instead, for realistic results, use Principled BSDF with transmission of 1, if you're using eevee, you will need to enable screen space reflections and refraction in render settings, check refraction checkbox in material settings and set refraction depth to something other than 0.

$\endgroup$
1
  • 1
    $\begingroup$ Hi and thanks for the comment. Using glass and transparent shader together works fine in cycles (and Eevee) and allows to control the density of the texture of the glass shader. In this case I have a glass scratches texture which on it's own would be too strong. If I use a glass shader I can control the refraction angle. The issue here really is that everything works fine in GPU mode but not CPU. This was true whether I used transparent or glass shader on their own. I will try to post the elements later today and see if anyone can replicate. $\endgroup$ Nov 14 '20 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.