I'm working on a model and I'm trying to export it in .gltf format.

In blender, I put a light to brighten the model, but when I export it, the lighting goes away.

I'm quite new to blender and I've tried some things, such as using a tool called ssgi but with no success.

What should I do to have the lighting in the export?

With lights

The model with the light when I'm working in blender.

Without lights

The same model but with no lights when I preview it.


1 Answer 1


There's an "Include: Punctual Lights" option in the exporter that will include point, spot, and directional lights in your exports. However, note that (by default) Blender also displays "Scene World" lighting, and you can't just export that. You'd typically need to enable it in whatever viewer or 3D engine you are using to view the model, and that depends on the engine. A typical term for this would be "IBL" or "environment maps" in some engines. Metallic materials, in particular, require this type of lighting to look correct.

  • $\begingroup$ Thanks for your answer Don. I tried what you said with the export option, and just to test it, I imported it in a new blender project but there was no lighting. Also, forgot to mention I'm using the 2.83 version. $\endgroup$
    – Fire Frost
    Commented Nov 5, 2020 at 9:25
  • $\begingroup$ You may want to file a bug on github.com/KhronosGroup/glTF-Blender-IO then. Another option would be to run gltf-transform inspect model.glb (with gltf-transform.donmccurdy.com/cli.html) and see if the KHR_lights_punctual extension is listed at the top. If so, the file contains lights and your engine may not be importing them. If not, they aren't being exported. $\endgroup$ Commented Nov 5, 2020 at 20:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .