2
$\begingroup$

I am having an issue with a rendering. I am trying to render a outside architecture scene with a sky texture (nishita) For some reasons, there are some black stains/pixel in some random areas of the render...

I'm using blender 2.90.1

Here is the file :

Any thought ? :D

enter image description here

Thanks

Valentin

$\endgroup$
4
  • 1
    $\begingroup$ What render engine are you using? What are your render settings? (Especially your shadow and ambient occlusion settings) $\endgroup$ Nov 4, 2020 at 10:18
  • $\begingroup$ Hi ! I am rendering in cycles $\endgroup$
    – valentin
    Nov 4, 2020 at 10:46
  • $\begingroup$ at 400 samples Ambiant occlusion factor .1 and distance 10 $\endgroup$
    – valentin
    Nov 4, 2020 at 10:51
  • 2
    $\begingroup$ Hi @valentin :) Please add new information to your question as an edit rather than as comments so that other users will see them in the text of your question. I would suggest adding much more info so that your question is more clear as well. Thanks :) $\endgroup$
    – Timaroberts
    Nov 4, 2020 at 12:25

1 Answer 1

5
$\begingroup$

Be careful with the musgrave texture. Its values are not constrained to the [0...1] range, which can result in negative values. The roughness is not supposed to get negative values, thus the black artifacts.

An easy fix is to add a clamp node, which will constrain the result between 0 and 1.

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you so much ! That was a tricky one ! $\endgroup$
    – valentin
    Nov 4, 2020 at 16:23
  • 1
    $\begingroup$ Hi! If that answer did help to solve your issue, please consider to accept and upvote the ansewer @valentin How this site works: blender.stackexchange.com/tour $\endgroup$
    – brockmann
    Nov 22, 2020 at 17:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .