Using blender to create a climbing wall for my garage. The modelling is fine but I now have laid out all the plywood shapes, flat on the 'ground' and am preparing to arrange shapes for optimum wood cutting (to reduce waste offcuts).

There are a lot of 'shape nesting' tools online that will figure this out, but many take dxf formats. I.e I am trying to use this one: https://webclient.nestingcenter.com/

I need to export each of my 3d plywood shapes to an individual 2d ( just the x-y area shape as all are 16mm deep ) dxf shape so I can import them to a shape nesting tool. Is there an easy way to do this? Can I convert one face of a 'cube' to a 2d DXF shape?

I have tried selecting my plywood panel shapes and using the Blender DXF Exporter but a) I think this is exporting a 3d shape, b) When I export, half of my shape vanishes and c) when I try to upload on nestingcenter, I get a message that the files contain invalid geometry (perhaps to do with them being 3d instead of 2d).

I've tried a few different settings in the exporter, but as I don't understand them fully, I am not choosing based on a good reason.

EDIT: I created a cube from scratch, selected one face and the DXF exporter worked fine... I don't know why this isn't working for my other shapes... they all started as basic cubes and just had some of their edges moved around to make the irregular shapes of the panels.


1 Answer 1


Just lay them out flat in XY plane and then delete faces only leaving polygon edges only, export as DXF. That's all.

Also keep in mind 1 unit in Blender is usually 1 meter while a lot of software expects 1 unit in DXF file to be 1 mm. It should be possible to define the units when importing DXF, however it's not always so. You might need to change Blender's unit scale and scale your models up.

  • $\begingroup$ Thanks. This worked, kinda. Once I deleted all the faces that I didn't need, some DXF exports were still throwing an error. This appears to be resolved by applying all transforms before export. $\endgroup$ Nov 3, 2020 at 13:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.