1
$\begingroup$

Whenever I try to do camera tracking on a video that was shot in portrait mode (1080x1920 pixels), I fail to get a proper result. In the 3D view (with the video footage as a background) the trackers don't end up in the right place:

enter image description here

When I take the exact same video and rotate it 90 degrees before importing it in Blender, I get the correct result:

enter image description here

I am using Blender 2.90. In both cases I do the tracking using Motion Model = "Location" and Match = "Previous frame". I keep the default camera settings that Blender uses for a new scene, and solve the camera motion using Refine = "Focal Length, Optical Center, K1, K2)". Then I set the floor, origin and y axis using the exact same trackers.

Of course I could do camera tracking on portrait scenes by rotating them first, but that would be very inconvenient: looking through the camera with the video background, I would have to work on a scene that was rotated 90 degrees.

My question: is it possible to do camera tracking in Blender using a video in portrait mode? If so, what should I do to make it work?

NOTE: A workaround would be to turn a portrait video into a landscape video by adding black bars to the left and right. I already tested this, and it works. But I would still like to know how to do camera tracking on a portrait video. You'd think this should be possible in an era in which portrait videos are almost more common than landscape videos.

An example of a portrait video for which blender gives an incorrect camera tracking result, can be found here: https://app.mediafire.com/icyvdawxlli8q There you'll also find the same video in landscape format, that doesn't cause any problems.

$\endgroup$
9
  • $\begingroup$ try changing location to perspective $\endgroup$ – SHikha Mittal Nov 4 '20 at 12:34
  • $\begingroup$ That helped to get the solve error (previously 0.85) down to 0.52. Thanks for that! Unfortunately, it didn't fix the problem that the track marks end up in the wrong place in the 3D view. When I do camera tracking on the horizontal version of the video, I get a solve error of 1.38, but a perfect match in the 3D view. $\endgroup$ – Frank Nov 4 '20 at 13:17
  • $\begingroup$ you have more than 10 tags , you can remove some poor tags and try if you could get a sub 1 solve error , and if you are done , can i write it as an awnsere $\endgroup$ – SHikha Mittal Nov 4 '20 at 13:35
  • $\begingroup$ As you can see in the picture above, I get a decent match for my markers even with a large solve error 1.38. That is: in the case of horizontal footage. For vertical footage it doesn't matter how low the solve error is: in the 3D view all the tracking markers end up far from where they should be. The question is: why is that? $\endgroup$ – Frank Nov 4 '20 at 13:53
  • $\begingroup$ See idk if there is a legit answere for why is that , but see some things are provided so that the machine can understand your intensions properly and give desired results so actually perspective is for most cases in motion tracking. $\endgroup$ – SHikha Mittal Nov 4 '20 at 13:56
1
+50
$\begingroup$

Portrait

  • Under Solve tab check Refine > Focal Length, Optical Center, Radial Distortion with those I got nice error only 0,10 px
  • Set Floor, Wall, Center, XY axis - with that I got camera correctly orientated

The only one thing that didn't match was camera Focal Length (and Shift).

  • If you select camera and go to Properties editor > Object Data > Camera > Sensor Fit and switch to Horizontal > Width 35 mm.

It does not fix the value itself, but empties and reconstructed scene match perfectly.

enter image description here

I still don't know why the given Focal Length is incorrect, but I'm not a tracking guru :) Alternatively you can adjust Focal Length and Shift manually according generated Empties.

Notes

How to determinate Lens Distortion
How to get better result ...

$\endgroup$
4
  • $\begingroup$ Thanks, that worked, although I needed different shift-values to make the markers match the video. If nobody finds a way to make it work without manual tweaking of the camera settings, I will mark this answer as THE solution! $\endgroup$ – Frank Nov 6 '20 at 15:36
  • $\begingroup$ Yes, I created the test scene with a camera with Focal Length 50 and Shift 0. $\endgroup$ – Frank Nov 6 '20 at 16:34
  • $\begingroup$ Edit: Can you try to change Camera Object Sensor Fit to 35 mm? $\endgroup$ – vklidu Nov 6 '20 at 17:34
  • 1
    $\begingroup$ YES!! That is the simple solution I was looking for (sensor fit = Horizontal, width = 35 mm). Thank you very much! Could you add it to your official answer above so I can mark it as "Accepted"? The funny thing is that yesterday I advised somebody else to use the Sensor Fit setting (blender.stackexchange.com/questions/201097/…) without realizing it could be the solution for my own problem too. Thanks again! $\endgroup$ – Frank Nov 7 '20 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.