I need to unwrap a huge mesh and Blender stops responding each time I try. Blender continues to use my cpu at 15%. Does that mean I have to wait and the operation will eventually be successful? In this case, is it possible to force Blender to use 90% of my cpu to go faster?

Thanks for your help, I loose a lots of time of this.

  • $\begingroup$ Is that 15% across all your CPU cores? Check if you have one CPU core at 100% (and the other cores idling). If so, you can probably let it run and it will finish eventually. Also, you can try to unwrap only certain parts of the mesh at a time. $\endgroup$ – michaelh Oct 30 '20 at 14:58
  • $\begingroup$ Thank you for your answer. On my 8 CPUs, I have some spikes at 100% on 2 CPUs, but most of the time it is close to 20%. It's been one hour now, I really don't know if I need to wait or not. I would like to try the unwrap by certain wraps, but is it possible to merge it after ? $\endgroup$ – Stef Oct 30 '20 at 15:13
  • $\begingroup$ No expert on UV unwrapping, but yeah, you can simply select faces of your mesh and unwrap them. Place them in UV space wherever you like. Then move on to the next set of faces. If you select the first faces again, you'll see that they stayed where you put them. No need to merge anything. $\endgroup$ – michaelh Oct 30 '20 at 15:22
  • $\begingroup$ I will try this, thanks again ! $\endgroup$ – Stef Oct 30 '20 at 15:29

Here's an answer with a short little gif to show what I meant in my comment.

You can unwrap parts of the mesh at a time and they will stay in place.

Hope this helps!

Unwrapping example

  • $\begingroup$ Cool, thank you it helps a lot, I hope it will work with my huge landscape ! $\endgroup$ – Stef Oct 30 '20 at 15:47
  • $\begingroup$ Great! Be sure to mark as solved if this actually worked for you. Have a good one! $\endgroup$ – michaelh Oct 30 '20 at 15:54
  • $\begingroup$ I still have the problem, even with this technic, it is crashing during the final step. Anyway, I will mark it at solved and will try another solution (probably using another software). Thanks again ! $\endgroup$ – Stef Oct 31 '20 at 11:42
  • $\begingroup$ Maybe try to isolate the problem. (I.e. a specific part of the model, etc.) See if it crashes on a small scale as well. If so, you could try to fix that one part and/or file a bug report. $\endgroup$ – michaelh Oct 31 '20 at 12:11
  • $\begingroup$ When I isolate, I works, but my problem is the huge mesh. I will try to decimate it more and maybe splitting it in different meshes (but the workflow will be more complex). $\endgroup$ – Stef Oct 31 '20 at 18:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.