1
$\begingroup$

I'm still pretty new to modeling and rigging, so apologies if this question seems obvious. But I tried to apply a skeleton and rig to a mesh I was working on. Things seemed to be fine, until I switched the rig from Rest Position to Pose Position: before I had even made any changes to the rig, it deformed the mesh heavily. The face seems to have been hit the hardest, sagging and being pulled forward around the mouth and eyes.

stretching/sagging deformation can be seen here, particularly around the eyes and mouth

If it helps clarify things, I set the rig as the mesh's parent using the following path: "Parent>Armature Deform>With Automatic Weights". This was the Armature Deform option which seemed to be causing issues with mesh deformation, but it also seemed to be the mode which lent itself to posing most easily (the two are likely related, but I don't know how to troubleshoot this).

Do you have any troubleshoot options I can try to fix this, or can you otherwise recognize what the issue is? I'll attach the Blender model here for reference, in case you can find the issue here.

to save space, the model has been compressed into a .zip file

$\endgroup$
  • $\begingroup$ i've edited my answer, I'm not familiar with too complicated armatures, but I guess you can apply the Pose as a Rest pose, so that you won't have this problem once you switch from Rest to Pose $\endgroup$ – moonboots Oct 30 at 10:00
1
$\begingroup$

It's because of the bone called DEF-chin.R (here in Rest Position):

enter image description here

you'll be able to see it if you enable its visibility in the armature layers:

enter image description here

You've given it a Damped Track and a Track To constraint with the bone called lips.R as Target, so as soon as you switch your armature to Pose Position it will point towards it:

enter image description here

When you parent a mesh it takes the armature Rest Position into account, and not its Pose Position, so when your armature switch to Pose Position, the bone will automatically move or rotate towards its target.

So you need to make sure that the position of this bone in Edit mode (i.e. their position in Rest Position) is the same position and rotation as in Pose mode, and reparent.

In Pose mode you can go in the header menu > Pose > Apply > Apply Pose as Rest Pose. Make sure to duplicate your armature first so you can come back to a previous version.

| improve this answer | |
$\endgroup$
  • $\begingroup$ I see — thank you very much! I thought I’d set all of the bones to “Clear Pose Transforms” in the armature before (in laymen’s terms, is that roughly what you were getting at for troubleshooting?), but I’ll double-check and make certain I do it right this time! I relied on the default human meta-rig for this, so admittedly I’m not as familiar with where everything is as I should be. Just to be certain, which bone is that that you’re pointing to? Could you send a more zoomed out view of it, please? (Also, sorry! I tried to comment to your answer, @moonboots, but I’m not really used to this site $\endgroup$ – modeaSculptor Oct 30 at 8:15
  • $\begingroup$ I've edited my answer, I hope it helps, I think header menu > Pose > Apply > Apply Pose as Rest Pose may fix the problem, but keep a copy of your file somewhere to make sure you can come back to it if necessary :) $\endgroup$ – moonboots Oct 30 at 10:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.