2
$\begingroup$

I attached an image texture to the head of my model and it shows up in render and when another object is selected in texture paint, but when I select it in texture paint it's purple again. I've tried finding missing links and nothing changes I'm not sure what is wrong I edit the image and the edits show up in render too so I'm not sure why my model is disconnected from it.enter image description here

$\endgroup$
3
  • $\begingroup$ (PS: I like your phantump) $\endgroup$
    – ETHAN DAY
    Oct 30 '20 at 2:56
  • $\begingroup$ Thanks, I'm giving him a pumpkin head for Halloween lol. $\endgroup$ Oct 30 '20 at 3:57
  • 1
    $\begingroup$ Hello :). Please mark the answer as Accepted if it solved your problem :). $\endgroup$ Oct 30 '20 at 8:15
2
$\begingroup$

In order to be able to view your image texture in texture paint mode, you need to do a few things first. Just follow my instructions, and hopefully it works. first, make a new image in the image editor section.enter image description here set your image settings, then create your image enter image description here once you have done this, make sure you have the desired object selected, and go over to the textures tab: enter image description here once in the textures tab, click on "New texture" Then scroll down and open the image that you want to paint onto the mesh: enter image description here next, go into the tools tab enter image description here once in the tools tab, change the mode from "material" to "single image" enter image description here next, click the little drop down tab underneath the mode settings, and select the image you had previously made (see first 2 images) in this case, mine is named: "new image" enter image description here once that is done, your image should show up on your mesh when you paint over it. You can change the texture paint settings as desired in the tabs below. enter image description here

PS: If it is still not showing up after you've done all those steps, try going into the materials shader editor, press "add" search for "image texture" and then hit the little texture tab to the left of the words "new" and "open" and then select your previously made image, and lastly, attach the node to the "base color" in your "principled BSDF" node.

PPS: if by chance your textures show up in weird places on your mesh when you paint, try selecting the object, go into edit mode, and press "Shift+N", to recalculate the normals.

And that should be it, if you need further assistance, feel free to ask. Hope I've been helpful! :)

$\endgroup$
2
  • $\begingroup$ Ah i see I accidentally detached the texture slot thanks a ton! $\endgroup$ Oct 30 '20 at 3:57
  • 1
    $\begingroup$ @Nicolas Alexander Lomas no problem! happy to help :) (btw, can you mark my answer as accepted? just click the check mark) $\endgroup$
    – ETHAN DAY
    Oct 30 '20 at 4:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.