0
$\begingroup$

A weird bug has appeared when I view through the default Front Back and Side camera views in Blender. The square grid has an odd triangular effect (see image below). This happened a couple of days ago and seems to have happened over night. It doesn't effect modelling or renders (as far as I've noticed) but it's quite annoying to see - especially when I don't what's caused it.

This only seems to happen when viewing through cameras on the axis (numpad 1,3 and 7) and occasionally in the orthographic view (numpad 5). Normal perspective cameras don't have this issue.

I've looked around and can't find an answer to the issue though, if I'm honest, I don't know what to be searching for. I've also uninstalled the software, re-installed, reset preferences to factory setting etc. but still get the same result.

Has anyone had this issue before and resolved it? I have accidentally changed a setting and not realised?

Thanks in advance

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Hello :). This looks like a GPU issue (although a cool one). Update your GPU drivers or perhaps try a different Blender version. $\endgroup$ Oct 29 '20 at 9:14
2
$\begingroup$

Use Alt + B to clear the clipping region, or use the menu View > View Region > Clipping Region.

$\endgroup$
1
$\begingroup$

Have had the same issue for a while - not a GPU problem.

I am using mac _ not sure if this is relevant but I have just fixed it by going to the "view" settings of the N panel. I am guessing you have a pretty huge number for end clip plane. I reduced that number and the grid got fixed.

I think blender viewport gets confused when it tries to calculate a very very long clipping plane.

Hope this works for you too!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.