0
$\begingroup$

Created an armature for a bird using animals meta-rig (I have downloaded a .blend file of a bird and trying to rig it)

I have adjusted all the bones to their places. Using object mode, I generated a rig (but that rig was way too small, so I have scaled it) Now I selected the bird Mesh and Shift selected the armature

When I am pressing CTRL+P I am not getting the option of deform (Originally, I thought this is happening due to behavioral changes in different versions, but more the videos i see, the more i am inclined to think this is the tipping point for my issue)

So as a workaround, I went to the Object option -> Parent -> Deform -> selected 'With automatic weights' (nothing noticeable seems to have happening here)

Then selecting the armature going to pose mode(ctrl+Tab)

When I am moving the armature, the bird is not moving.

Options I tried so far,

  • I tried joining with ctrl+J
  • Enabled the System Console to check the error (no error displayed)
  • My blender version : 2.82 (also tried with 2.83 version too)
  • Also ensured that "Auto run Python scripts" is turned ON in settings
  • Followed the instructions from this answer

I am fairly new to the world of Blender, and most of my knowledge is either through youtube videos or blender docs.

Attaching the file

$\endgroup$
1
$\begingroup$

This is the procedure to have your file working OK: select the rig and delete it. Select the Metarig and press Ctrl A "Apply all transform".

In the Rigify properties enable "advanced options", delete target rig and target UI and choose new (with a new name) as destination.

Press Generate rig.

Hide the Metarig.

Select the mesh, shift select the new rig (the order of selection is important), choose "with automatic weights" option.

The advanced option is necessary only if you generate a bad rig (wrong unapplied scale) and later you try to generate a new one: some conflict can arise between old rig (even if deleted) and new one.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for your prompt response, but no luck!!!! I am still not getting the mesh movement. I think I might be missing on something, so I have uploaded my screen capture for your reference. Please help youtu.be/d6j-ue1sFow $\endgroup$ – LionsDen Oct 29 at 18:57
  • 1
    $\begingroup$ The problemt is only your selection method: slected objects are orangy, active ones are yellow. If you use shift click the last clicked object gets active, while if you use box select the first one is active. Rig must be active when parenting. I also don't like this inconsistency, even if in some cases it's useful. When both are selected you can shift click on the rig until it gets yellow. $\endgroup$ – josh sanfelici Oct 29 at 20:05
  • $\begingroup$ Thanks a ton! It worked. I didn't realize the color change. So finally I have selected the mesh, then shift selected the rig, then selected the entire thing again to make it yellow, and it worked. $\endgroup$ – LionsDen Oct 30 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.