0
$\begingroup$

Alpha blend seems to result in the entire mesh being weirdly semi-transparent or something. enter image description here

In this object only the glass bottle has transparency yet the other components have this effect as well even though they have no transparency. I'm using a png file with a black and white mask applied to the basecolor.

Any solutions to this?

$\endgroup$
  • 1
    $\begingroup$ Stop using the absolutely worst designed image encoding format known to humankind; PNG. It’s complete garbage, and does not belong in an imaging pipeline. Blender should wake up and remove it from being default, giving it an air of validity. It is pure garbage. $\endgroup$ – troy_s Oct 27 '20 at 3:55
  • $\begingroup$ Hello :). Maybe your UV map is overlapping? Do you use a second material for the non-transparent parts? You can also share your file $\endgroup$ – Jachym Michal Oct 27 '20 at 7:07
  • 1
    $\begingroup$ I think you need to disable "show backfaces" in the same panel where you enabled the alpha blend $\endgroup$ – Gorgious Oct 27 '20 at 7:28
  • $\begingroup$ here is the file $\endgroup$ – Wonkey Oct 30 '20 at 3:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.