1
$\begingroup$

I'm trying to animate a blink using textures and I am using a two image texture connected to a mix colour node and when I move the "fac" slider the textures do not change. I do not know what I have done wrong, any help please? (Keep in mind, I am a beginner so I don't really know that much about Blender) enter image description here

$\endgroup$
5
1
$\begingroup$

Ok so as you're using a MixRGB, you can indeed mix the 2 Image Texture nodes into the MixRGB, then you need to plug the MixRGB into a Diffuse, then the Diffuse into an Output:

enter image description here

MixRGB is used to mix 2 colors and/or images, but you need to tell Blender what kind of shader it is supposed to be, between Diffuse (which will be affected by light and shadows) and Emission (which emits light). In your case I guess you need Diffuse.

Another equal solution would be to use the Mix Shader, in that case you need this setup, as Mix Shader doesn't directly accept images or colors:

enter image description here

$\endgroup$
3
  • $\begingroup$ thank you so much! the place where i went wrong was that i wasn't in rendered view i was just in the standard one so that is why it wasn't showing! tysm tho :D $\endgroup$
    – mxnisa
    Oct 26 '20 at 13:19
  • $\begingroup$ oh ok, anyway the Diffuse and Output were missing so you wouldn't have been able to see anything $\endgroup$
    – moonboots
    Oct 26 '20 at 13:21
  • $\begingroup$ yeah i just added that in :) $\endgroup$
    – mxnisa
    Oct 26 '20 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.