4
$\begingroup$

I want to click the green manipulator, not the red one.

enter image description here

However, if two manipulator (red & green) appear moderately close together from the camera, Blender will think that I click the one that is near camera (red).

The below dot-gif image shows my clicks.
All of 3 scaling tests were done by clicking the green.

  • In the first two tests, Blender wrongly think I click the red manipulator.

  • In the last test, before I clicked, I rotated camera a bit and get the expected correct result.

enter image description here

How to reduce the distance threshold that Blender use?

enter image description here

^ To make testing convenient, I wish for an answer that works when I click the yellow zone.
Currently, if I click the yellow zone, Blender will wrongly think I click the red manipulator.
However, if I click the cyan zone, Blender will correctly think I click the green manipulator.

Environment :

  • Blender 2.81 & 2.83 & 2.90 & 2.91(experimental) in Windows 10.
  • Blender : switching because Industrial and Blender-default keymap doesn't help.
  • Windows : It can't be fixed by Display>Scale and layout>Advanced scaling settings> = 100%.

Environment that there is no issue:

  • Blender 2.81 in Windows 7.
  • Blender 2.81 in the problematic computer. It needs factory reset.
    The trick has no effect on Blender 2.90.

Bounty Reason (old)

  • HikariTW's answer is a good attempt, but sadly, for my case, it isn't useful at all.

  • Jachym Michal's is very insightful, but it doesn't provide any solution except (bug) reporting.

  • Increality's provides a doable solution. However, for me, it is (very) inconvenient.

  • Yudaka's argues that there is no such issue in his machine, and I confirm later that there is actually no issue in one of my computers.

$\endgroup$
8
  • $\begingroup$ What version of blender? Not seeing the behaviour as demonstrated by @JachymMichal in 2.91. (Each has a similar circle of influence) $\endgroup$
    – batFINGER
    Oct 31 '20 at 17:22
  • $\begingroup$ @batFINGER :: Thank, I tested in 2.83 and 2.90 (will add info to the question). I will try 2.91 $\endgroup$ Nov 1 '20 at 0:28
  • $\begingroup$ @batFINGER :: I just tested 2.91. The issue still exists. Did you try to click the yellow zone? I didn't test Jachym's assumption yet. $\endgroup$ Nov 1 '20 at 0:40
  • 2
    $\begingroup$ git.blender.org/gitweb/gitweb.cgi/blender.git/blob/refs/heads/… If that code is indeed used for all tools that involve (mouse) selection, then the distance threshold, or hitbox, is hardcoded. Radius of 14px from center point of selection which is 28×28px. But when I test your file, I don't find any issue when I click teh yellow zone. $\endgroup$
    – Yudaka
    Nov 4 '20 at 18:04
  • 2
    $\begingroup$ I use version 2.90.1 on Arch Linux. Did you use same mouse you used for this question? It could be the mouse, or even the setting on your OS. $\endgroup$
    – Yudaka
    Nov 5 '20 at 1:23
6
$\begingroup$

This is due to Perspective view.
I seems that closer control points have larger "active area" around them. because reasons...?

In Orthographic view, the active area around all points is the same :).


Active areas highlighted. When cursor is in 'active area' it changes from a cross ✛ into arrows ✥ enter image description here

This doesn't make much sense from the UI standpoint, the 'active area' shouldn't change due to perspective.
It would also be nice if the 'active' point was highlighted when the cursor gets close enough.


Possible solution:
Suggest improvements on devtalk.blender.org or rightclickselect.com and wait until they're implemented.

$\endgroup$
2
  • $\begingroup$ How did you know? Do you draw the circle by yourself or via enabling some Blender setting? $\endgroup$ Oct 30 '20 at 1:47
  • 1
    $\begingroup$ I didn't know :). I tried and tried to find the reason because it was driving me crazy :). And the circle is just an icosphere $\endgroup$ Oct 30 '20 at 6:17
2
$\begingroup$

You could lock your Scale on the X axis before performing the operation, so that it is not affected by the Scale Cage, thus giving you the desired result.

enter image description here

$\endgroup$
3
  • $\begingroup$ Thanks. It would work, but in a very frustrating way. Pressing key X/Y/Z to lock can work too in some cases, but has the same disadvantage. These solutions are far from what I wish for. $\endgroup$ Nov 4 '20 at 1:04
  • $\begingroup$ I imagine messing with the source code might be what you need, perhaps following this guy's lead, and applying it to the Scale Cage blenderartists.org/t/… This video shows source code access: youtube.com/watch?v=Vm2-sUueEEc $\endgroup$
    – Increality
    Nov 4 '20 at 1:52
  • $\begingroup$ I agree. Perhaps there is no other ways. $\endgroup$ Nov 4 '20 at 2:53
1
$\begingroup$

You might be able to disable this behavior in setting > Viewport > Selection > [] OpenGL Depth Picking:

enter image description here

This option will select the object with the least depth, which seems not what you want.

$\endgroup$
1
  • 1
    $\begingroup$ It can't correct the behavior for my tests. Nice try. Thank. $\endgroup$ Oct 26 '20 at 5:46
1
+50
$\begingroup$

view3d_select.c#1722

If that code is indeed used for all tools that involve selection with mouse or any pointing devices, then the distance threshold, or hit-box, is hard-coded. Radius of 14px from center point of selection which is 28×28px box. But when I test your file, I don't find any issue when I click the yellow zone.

This could be an issue with your mouse or even the setting on your OS. Try with different mouse, computer, or different OS.

EDIT

This thread on BA allude to similar problem. While in this reddit post, the OP having difficulty on selection. So, most of the issues I think related to compatibility and graphic driver.

I also found this discussion (T73479) on Blender Developer about Select Through you maybe find it interesting.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.