I am trying to animate a simple scene in which apples fall from above into a bowl.

  • I added rigidbody physics to the bowl, made it passive, set the collision to mesh, and set the margin to 0.01.
  • I then placed the apple above the bowl, gave it rigidbody physics, kept it as an active object, set the collision to mesh, and finally, set the margin to 0.01.

When I hit the play button, the apple seems to be reaction normally at first, but when it hits the bowl, it starts to slowly vibrate and rotate. Does anyone know why this is happening? Any help would be appreciated. I will give the link to my .blend file below.


  • 1
    $\begingroup$ This is common and can be eliminated by (1), setting the physics cache's 'END" frame to one that allows the object to fall and settle. With the engine switched off at that frame there'll be no 'wrestlessness'. The 2nd alternative when physics is still needed is to bake the object's fall into the bowl up to where it settles. Once baked, get rid of it's physics properties altogether BEFORE playing the result. There will be two redundant physics strips left in the Dopesheet. Delete those strips also. If still not right, save the project, exit Blender and reload. $\endgroup$
    – Edgel3D
    Oct 26, 2020 at 5:50
  • $\begingroup$ Further to the above - Settings can be tweaked that will reduce this, even stop it but it's a flddly process, particularly for Newbies and is easily upset, cannot be guaranteed to work indefinitely. $\endgroup$
    – Edgel3D
    Oct 26, 2020 at 5:52


You must log in to answer this question.

Browse other questions tagged .