I'm making a candle, using a Mantaflow fire simulation, and all looks good in solid view. But when I switch over to Cycles rendered view, the flame looks very blocky and low resolution. It looks the same in the final render too. I followed tutorials using Quick Smoke to set up the flame, but for whatever reason mine always turns out looking way worse than theirs.

I've tried applying the scale of the Smoke Domain and Emitter objects, raising the resolution divisions on the domain from 64 to 128, and lowering the step rate of the domain material. None of these made any noticeable difference.

I'm quite stuck here, so any ideas would be much appreciated.

Solid View

Render View

  • $\begingroup$ I am not sure why your fire would look lower res in Cycles with the same settings as EVEE. I added an answer as to how to make it look higher res, but I don't know - we may be missing something. I think that 64 res should be high enough to get a better-looking candle flame! $\endgroup$
    – RBlong2us
    Dec 22, 2020 at 22:00

2 Answers 2


I've animated flames in blender a few times in the past, and one thing I learned is that if you want the flames to look realistic. You usually have to set the resolution divisions REALLY high. Around 600 or even 700 division should make it look really nice. Or maybe 400-500 if you're not going for super realistic. Yes, it will drastically increase your rendering time, but that's the price you have to pay sometimes.

  • $\begingroup$ Alright, I'll give that a try. Thanks! $\endgroup$ Oct 26, 2020 at 3:23
  • $\begingroup$ you can also add noise with mantiflow and use a way lower even 128 can do the trick sometimes $\endgroup$
    – J Block
    Dec 22, 2020 at 10:00

For Those Using Cycles:

I think that raising divisions is definitely a good way to add detail to your fire. however, I would suggest keeping it below 200 if possible. Adding divisions will definitely slow down the render process.

Another way for you to add resolution to the fire is by enabling the Noise settings under the Domain's Physics settings. I would suggest you try this option before drastically raising your divisions. The Upres Factor I've heard is like multiplying the divisions amount by the number set in the field. If you enable this setting and set the Upres Factor to 2, it should help your fire look more realistic. I've been told that 2 is the highest you should bother to set it, as raising it higher does not add much more detail.
Hopefully by enabling the Noise property you will be able to raise the detail in your fire without drastically raising Render times. Also, Be sure to bake the Fire settings and the Fire's Noise Settings.

For Those Using EVEE

If you are using EVEE, try this method before you start upping your fire's resolution divisions. Be advised that I am not using more than 64 resolution divisions in the following photos. My render samples are set at 64 for these pictures.

Here are the settings I am changing:


enter image description here This picture has volumetric settings of 8px Tile Size and Samples of 86. As you can see (especially if you right-click and view image), it is pretty blocky.


This picture is set to Tile Size of 2px and Samples of 86. The fire has better detail.

2px256samples This picture has a Tile Size of 2px and Samples of 256.

From what I've seen from these renders I have done is that lowering the Volumetrics Tile Size to 2x will greatly help improve the quality of your fire simulation - without you having to increase your fire resolution divisions to a huge amount. The volumetrics samples may add some detail to your fire, but 256 samples (which is the max amount) is probably overkill for your fire.

Try these settings before you start increasing your fire resolution divisions. Definitely lower the tile size to 2px, and mess around with the samples amount to see how it affects your fire. Overall, this should improve your fire without increasing your render time to such a huge amount as increasing divisions would.

  • 1
    $\begingroup$ This is a great answer for EEVEE but he said he was using cycles so this doesn't apply to him. Though this is a great answer for people looking for answers for EEVEE $\endgroup$
    – J Block
    Dec 22, 2020 at 10:03
  • $\begingroup$ Thank you for this comment! I didn't realize the settings I changed were not applicable to Cycles. I clarified the answer and added some detail. Let me know what you think! $\endgroup$
    – RBlong2us
    Dec 22, 2020 at 21:41
  • $\begingroup$ That's perfect. great! very helpful. I have been looking for something like this because it always came out looking weird. Thanks! $\endgroup$
    – J Block
    Dec 23, 2020 at 5:42
  • $\begingroup$ No problem! Thanks for the comment! :D $\endgroup$
    – RBlong2us
    Dec 23, 2020 at 6:21
  • $\begingroup$ Also make sure that the flame density is set high enough and the domain is big so that the flames are not cut by the domain borders. These things can cause block artifacts even in high-res simulations. $\endgroup$
    – Hitokage
    Mar 12, 2023 at 8:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .