0
$\begingroup$

System Information Operating system: Linux-5.8.0-25-generic-x86_64-with-debian-bullseye-sid 64 Bits Graphics card: AMD TURKS (DRM 2.50.0 / 5.8.0-25-generic, LLVM 11.0.0) X.Org 3.3 (Core Profile) Mesa 20.2.1

Blender Version Broken: version: 2.90.1, branch: master, commit date: 2020-09-23 06:43, hash: rB3e85bb34d0d7 Worked: (newest version of Blender that worked as expected)

Short description of error I get contrasted triangles throughout the interface, everywhere. Ill attach screenshot to understand the issue better. Some materials are also displayed transparent so matter what settings I tweak, and sometimes the model appears to have many black triangles inside it where there is no mesh, inside the empty spaces. I am sure this a graphical issue, but I have tried to install additional drivers and drivers from official sites and ppa's but nothing has worked. As you can see everything has two contrasted triangles, and the selected faces should be black as set by the shader but its shown transparent in viewport and material view

$\endgroup$
3
$\begingroup$

TL;DR: Your GPU does not fulfill the minimum requirements for running Blender 2.8x or later.


"Turks" is part of the codename of multiple GPUs that have the TeraScale 2 micro-architecture:

In order to run Blender properly, your hardware has to fulfill the minimum requirements. For AMD graphics cards the micro-architecture has to be at least GCN first generation or later. This is to ensure normal operation, GPU rendering has higher requirements. At the time of writing the minimum requirements for graphics card for Blender 2.8x and 2.9x are:

Supported Graphics Cards

  • NVIDIA: GeForce 400 and newer, Quadro Tesla GPU architecture and newer, including RTX-based cards, with NVIDIA drivers (list of all GeForce and Quadro GPUs)
  • AMD: GCN 1st gen and newer (list of all AMD GPUs)
  • Intel: Haswell and newer (list of all Intel GPUs)
  • macOS: version 10.13 or newer with supported hardware

Unfortunately, this means that your GPU is below the minimum requirements and not officially supported. You may still be able to run Blender, but graphics glitches or even crashes, due to issues with the graphics driver, may occur. Sometimes the graphic glitches can be resolved by installing a more recent graphics driver, if one is available.

Blender 2.79b is the last release that officially supported your GPU. Previous versions of Blender can be download from this page.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for the info so much! I can stop trying to 'fix' it and buy a new GPU now $\endgroup$ – Amber B. Oct 27 at 6:01
  • $\begingroup$ @AmberB. You're welcome. Avoid the AMD Radeon 5700 XT though. We get plenty reports that it doesn't work properly $\endgroup$ – Robert Gützkow Oct 27 at 8:22
  • $\begingroup$ Thanks will do, I am going for a gtx 1050 or 1070 right now. $\endgroup$ – Amber B. Oct 27 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.