0
$\begingroup$

I've seen this issue come up several times in multiple forums and there doesn't appear to be a clear way to resolve (for my situation).

enter image description here

My Goal: Export the model (above) I created in blender with material to Unity for testing. Once the model is in Unity, I should be able to 'Extract Textures' on the model so Unity automatically maps the textures. Note: I'm very much a beginner, especially when it comes to this exporting exercise.

Summary of General Issues: I've attempted many FBX exports, tweaking properties each time and using both the cycles render and blender render. For some reason the model doesn't appear to be able to bake the textures correctly, so that when I import to unity I can simply 'Extract Textures...'

Other Background detail: Running Blender 2.79b (haven't learned 2.8 well enough yet :)), I have my model with one mesh and one material. I've already UV unwrapped the mesh, and the model looks great in the 3D view.

1st attempt to resolve - I've clicked 'File -> Export -> FBX' from blender, and I've switch the 'Path mode' to 'Copy' and select the 'Embed Textures in FBX binary file...' I've attempted this a few times and this seems to do nothing. I also did attempt this in 2.8, and no effect.

2nd attempt - I then read in a separate article that texture data does not simply stay with your model (despite the above which appeared to work for other users), and you need to be able to 'Bake' your textures. I started with cycles render, and every time I clicked 'Bake', my UV image disappeared and I saw a black silhouette replace the original image. I then had to reload the image and tweak some of the settings. The image appears to bake. However, after attempting to import to unity, no texture appears to have come with the object (as the option is still greyed out to 'Extract Textures' in Unity).

enter image description here

3rd attempt - Reading a separate thread, cycles render may not be the way to go. I read that baking only really succeeds with blender render, however after ensuring I had my UV Image, having only 1 model, maintaining only 1 material, and attempting to tweak the baking settings, the UV image disappears, and the material doesn't appear to bake.

enter image description here

4th attempt - I also read that ticking the 'selected to active' box was important, however when I check that box, the UV image disappears again, and this time I have a 'No Object or images found to bake to' error.

enter image description here

Several attempts later - I've attempted tweaking nodes and ensuring the diffuse shader is enabled. I added a bright light into blender to ensure the baking could occur as I've read that could cause the silhouette.

Does anyone know and can clearly explain to me how to proceed accomplishing the goal above? I feel close, just banging my head up against blender and reading the documentation, and I feel like I must be missing something silly.

$\endgroup$
5
  • $\begingroup$ Hello :). Does this help? .fbx export why there are no materials or textures? $\endgroup$ – Jachym Michal Oct 25 '20 at 10:10
  • $\begingroup$ @JachymMichal Thanks for the response - I did check out the first response under 'gamefromscratch.com/post/2014/07/16/…', and followed the steps. Unfortunately baking still seems to be the issue. I have the 1 material, the UV already unwrapped as it needs to be, but whenever I select my UVs (CTRL + A), and attempt a 'full render' bake, it doesn't show the progress - it merely flips the image black. Is there likely a reason for this? $\endgroup$ – NFax Oct 25 '20 at 13:11
  • $\begingroup$ Hey :). I'm no expert on baking. Consider adding your comment into your question - and try different answers from the linked thread :). $\endgroup$ – Jachym Michal Oct 25 '20 at 13:18
  • $\begingroup$ Figured it out - The link from above got me about 75% of the way there. For some reason the texture was never showing after baking. Through a lot of trial and error, I found out I had to adjust the 'Shading' settings under the 'Material' property. For some reason, by clicking the box for 'Shadeless', the texture appeared. I exported using the steps explained in attempt #1 above, and then the 'Extract Textures' button was no longer greyed out in Unity! $\endgroup$ – NFax Oct 25 '20 at 14:08
  • $\begingroup$ Congrats :). Please add the solution as an answer (just copy your comment). It keeps the site organized and may help others with a similar problem :). Cheers. $\endgroup$ – Jachym Michal Oct 25 '20 at 14:14
0
$\begingroup$

Figured it out - The link from above got me about 75% of the way there. For some reason the texture was never showing after baking. Through a lot of trial and error, I found out I had to adjust the 'Shading' settings under the 'Material' property. For some reason, by clicking the box for 'Shadeless', the texture appeared. I exported using the steps explained in attempt #1 above, and then the 'Extract Textures' button was no longer greyed out in Unity! –

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.