13
$\begingroup$

I wonder if this is a bug, or if I missed something...
When a light hits tangentially convex surfaces with "smooth shading", the shadow on this surface seems to "partially ignore" the smoothness of the surface. Here is an example with a simple cylinder :

Cylinder test

On the left, a cylinder with "flat shading". Everything's ok.
On the right, the same with "smooth". We can see an edge, bad shadowed.

With or without the "Edge split" modifier, no matters, the edge is still there. The shader is a simple white diffuse shader with no texture nor displace.

I have to add a subsurf modifier with at least 2 levels, which will insanely increase the vertex count... And I can't do that for my project.

I hope someone already saw it, and have a little tip to share. Or if someone already know it's a bug, or a limit of the current Cycles renderer ?

$\endgroup$
  • 1
    $\begingroup$ That looks like an edge split to me. If you don't have an edge split modifier enabled, go into edit mode and press "W > Remove Doubles" $\endgroup$ – CharlesL Jul 26 '13 at 16:28
  • $\begingroup$ As I said, the edge split modifier doesn't affect this strange behavior. And, there is no double, because it's a Blender's default cylinder added from the menu "Add". $\endgroup$ – Polosson Jul 26 '13 at 16:31
  • $\begingroup$ Does it do the same thing with a sphere? $\endgroup$ – CharlesL Jul 26 '13 at 16:38
  • $\begingroup$ Yes it does ! Really strange, huh ? You don't have this issue ? $\endgroup$ – Polosson Jul 26 '13 at 16:41
16
$\begingroup$

I believe what you're looking at is called the "Terminator Problem" which is a ray tracing issue. I think most rendering engines actually suffer from this problem.

I think the solution is to add more geometry or play around with your lighting setup.

You can read more about it here. https://developer.blender.org/T37814

$\endgroup$
4
$\begingroup$

Ok so I tried to recreate what you where doing to see if I could run in to this problem.

I used a cylinder with 40 vertices and played around with lamps and light planes, no multi res or sub serf modifiers added. I found the best result for smoothness was using a hemi lamp.

These are at 200 samples 40 vert cylinder flat with hemi 40 vert cylinder smooth with hemi

Here is what my sene setup looked like.

What my scene looks like with the hemi lamp

Another way I like is to add a plane and add an emitter material to it and make a light plane. To keep the shape of the plane out of the scene I tilt it just out of the camera view finder. light plane scene alternate light plane

$\endgroup$
  • $\begingroup$ Is this really an answer to the question? $\endgroup$ – VRM Sep 29 '15 at 19:42
  • $\begingroup$ I recreated the problem and had no bug... Then showed my settings... I don't know all of their settings so if they want to find the answer they only have to look at what settings they have not done yet. It's how I learn so yes it is an answer. $\endgroup$ – Tessa Sep 29 '15 at 20:33
  • 1
    $\begingroup$ It doesn't appear to be the same issue to me, but ok. The illustrations are much different $\endgroup$ – VRM Sep 29 '15 at 20:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.