0
$\begingroup$

I've created a character and rig and it looks and works fine in Blender, however after I export to FBX and import to UE4 the bones are shifted. One issue is that the root bone moves to the floor and seems to pull all the other bones down with it. Also there are a few bones that are parented to the root bone with an offset, shown by the dotted lines:

enter image description here

However in UE4 those bones become attached to the root bone. Is there a way to make them keep their offset on import? The bones move the mesh just fine but are in the wrong location. For example, when I select the bone that is visibly where the upper leg is, UE4 thinks it's the lower leg:

enter image description here

My transforms are all applied. Not quite sure what's going on here, any suggestions welcome. Thanks

$\endgroup$
0
$\begingroup$

You can create a new root bone, which will be parent af all others rig's bones, and set it on the floor, so that UE will not have to move anything. Similarly you can replace every "keep offset" option with a new bone, so that all the bones chains will not be "interrupted". UE requires a general root bone that will be placed at loc (0,0,0). Every bone is requested to be weighted to one mesh vertex at least. If some vertices are not weighted to any bone, they will be automatically fully assigned to the root bone.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hi Josh, thanks for the tips. I moved the root bone down to the floor and replaced the offset areas with filler bones but UE4 still does the weird thing of attaching bones to the root, even though they are unparented from it and parented to a filler bone that connects the pelvis to the root, makin the whole structure out of whack $\endgroup$ – Amy Komili Oct 26 at 4:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.