I am trying to add a Subdivision Surface modifier to a mesh in Blender but it crashes.

It's really weird because it has only 117k tris so it shouldn't crash for 1 level of subdivision.

Could the problem come from the fact that I made this mesh in an another software and then I imported it in Blender as obj?

Also my PC can handle really high poly scenes, I often do sculpting and microdisplacemnt without any issue but this particular meshes keep crashing my PC.

EDIT: After reporting this bug, I was told to turn off GPU Subdivision in Preferences>Viewport>Subdivision. This worked for me.

  • $\begingroup$ Possible duplicate of: Render crash when using subsurf modifiers $\endgroup$
    – no-can-do
    Commented Oct 23, 2020 at 20:37
  • $\begingroup$ But his crash happens on render, while mine happens as soon as i add the modifier. Also he had multiple sub modifiers stacked on same object with too high sub level. I can't literally even just add it and it's weird because if i model a highly detailed mesh in blender (let's say500k tris) and subdivide it i have no problem in reaching millions of polygons. But this imported objs are only100k yet it crashes instantly and freezes my pc for 10min. It must have to do with the fact that it was an imported obj abd not a mesh made in blender idk it's the only thing that comes to my mind. $\endgroup$
    – Jack
    Commented Oct 23, 2020 at 23:46
  • $\begingroup$ i have same problem...when tray subdivide object with 49000 vertexes blender just not resoponding...ryzen 9 3900x 32gb 1660 super. did u solved problem? $\endgroup$ Commented Jan 17, 2021 at 14:41


You must log in to answer this question.

Browse other questions tagged .