0
$\begingroup$

I'm running Blender 2.8.3 on Ubuntu 18.04. I downloaded BlendLuxCore for Linux 64 bit and followed the instructions to install it as an add-on to Blender.

When I select the LuxCore render engine, set to render with the CPU, it fails to render and I get the following error message:

Error | OpenCL driver API error (code -1001, file:/home/vsts/work/1/s/LinuxCompile/LuxCore/src/luxrays/devices/ocldevice.cpp, line 72): -1001

This is very confusing because as I understand it, OpenCL is analogous to CUDA and is used for GPU computing. Why would this be an issue for CPU rendering? I found an identical issue to my question posted on GitHub, but I don't see how the response there helps. Do I somehow need to set up OpenCL drivers on my computer even if I'm only interested in rendering with my CPU? And if so, why?

In searching for a solution to this, I've seen references to there being different versions of LuxCore for CPU and GPU, but at least for the more recent versions the download page does not make this distinction, and the render properties panel allows you to select either CPU or GPU rendering.

$\endgroup$
1
$\begingroup$

So, I took a wild guess and installed the OpenCL running environment for my intel CPU only from this site: https://software.intel.com/content/www/us/en/develop/articles/opencl-drivers.html#latest_linux_SDK_release

After I did that, LuxRender works.

If somebody wants to add an explanation about why I needed to do this in the first place (I am partially confused because the LuxRender web site makes no reference to this being a dependency you need to set up before installing), that would be cool. But, my problem is solved, and I'm going to tentatively assume that LuxRender is using OpenCL as a sort of backend to abstract away hardware details like whether you are on a CPU or a GPU and what types.

| improve this answer | |
$\endgroup$
1
$\begingroup$

Without having an example scene, it is only a guess, but I suspect that the cause is that LuxCore by default uses OpenCL for the imagepipeline computations (simple compositing like tonemapping that is applied to the rendered image). You can disable OpenCL usage for the imagepipeline in the camera settings (LuxCore v2.4 or earlier) or in the addon user preferences, in the "Film Device" dropdown (LuxCore v2.5+).

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.