0
$\begingroup$

I am not sure if this is a limitation in Evee or a setting I am missing.

I am using Blender 2.9.0 on Mac OS X Catalina.

Making a scene (I know, my mom told me not to make a scene) and want to have a transparent container catch some lemons and spill them. However

Object material screen space refraction enabled

and it works fine, but NO REFLECTION.

But if I disable the refraction settings, I get a reflection, but I can no longer see the lemons! Oddly, I can see the environment image but not the lemons.

No screen space selections, no lemons, but background is seen

I did play around with the screen space refractions of the Lemons, but it had no difference.

This does work as expected in Cycles, but 350 frames will take 7 hours to render.

I appreciate suggestions, thank you in advance.

$\endgroup$
1
  • 1
    $\begingroup$ Proper reflections in eevee are dependent on "Screen Space Reflections" (not refractions necessarily), and the presence of a "Reflection Cubemap" (add through the add menu and scale to cover the area where you want reflections to happen). $\endgroup$ Oct 22 '20 at 16:04
1
$\begingroup$

This may be an answer from 2.9 manual...

Screen Space Reflections and Ambient Occlusion are not compatible with Screen Space Refraction; they will be disabled on the surfaces that use it. Surfaces that use Screen Space Refraction will not appear in Screen Space Reflections at the right place. Surfaces that use Screen Space Refraction will not cast Ambient Occlusion onto other surfaces.

I guess I must use cycles...

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.