0
$\begingroup$

This is my first time rendering in Cycles since I just figured out how much nicer it looks with normal lighting, but I'm getting a weird transparency effect on the objects when the scene is rendered with cycles specifically. Here is what the render looks like in Eevee:

enter image description here

As you can see, all of the objects are fully opaque except for the wings, which is what should be happening. However, once this exact setup is run in Cycles, it comes out as this: all objects are partially transparent

Needless to say, I did not want my character to turn into a ghost. If this is a common error or if I just missed a step, please let me know!

Here is the .blend file if that helps (ignore the name): https://www.dropbox.com/s/4um4cgaxtm2wyn2/FloraRenderOverwatch.blend?dl=0

$\endgroup$
1
$\begingroup$

You've plugged some image textures into the alpha socket of your Principled BSDF nodes, in Eevee it doesn't create transparency by default as long as you haven't enabled Alpha Blend, but in Cycles it automatically creates transparency. What is your goal with this setup?

enter image description here

Alpha is useful for example if you want to use the alpha chanel of a picture in order to create transparency:

enter image description here

$\endgroup$
  • $\begingroup$ my goal was “only god knows”, because I have no idea how nodes work $\endgroup$ – Toman800 Oct 22 '20 at 8:04
  • $\begingroup$ ah ah ok, alpha is useful for example if you want to use the alpha chanel of a picture ;) $\endgroup$ – moonboots Oct 22 '20 at 8:05
  • $\begingroup$ fancy, i’ll keep that in mind, thanks $\endgroup$ – Toman800 Oct 22 '20 at 12:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.