I'm new to blender, but looked at several videos and tutorials and tried to do it in 2.90.0.

Starting from a simple cube, created an array in 3D (3 arrays in X, Y and Z), fixed distance, leaving some space between them.

Entered Edit mode (array selected), here something was already strange, tried to see everything selected, was not possible until I´ve activated the Object Data Properties selector in the array modifier.

Then hit P and selected By Loose Parts, but nothing happens. Just keeps where it is.

When the Object Data Properties selector in the array modifier is NOT selected, then all the array does not select in Edit Mode.

After trying again and again, starting over, new file, etc. I´ve download version 2.83 LTS and made the same thing, and it worked. Tried 2.90.1 and this version also did not work.

Did something change in a way which is not documented and I´m missing something?

  • 5
    $\begingroup$ I might be misunderstanding the events here but would this be an answer? The array modifier doesn't actually add meshed copies of the object, meaning they can't be separated in Edit mode 'cos there's no extra objects to separate. The modifier would have to be "Applied" first. Go into the Modifier list and click on it's 'Apply' button. This will convert the 'ghost' copies to hard mesh, but all as one object. They can then be separated in Edit mode when all vertices are selected and 'P' is pressed. $\endgroup$
    – Edgel3D
    Oct 22, 2020 at 4:00
  • $\begingroup$ Script version re comment above blender.stackexchange.com/a/61254/15543 $\endgroup$
    – batFINGER
    Oct 22, 2020 at 8:02
  • $\begingroup$ Thank you for your reply, but in version 2.90, there is no more an Apply button, as there is in version 2.83. That´s a difference. That is why my question was also related to if there was any workflow change that was not documented and distinct to the way it´s done in 2.8X. In 2.8X I have used the Apply buttom. $\endgroup$
    – JS1970
    Oct 24, 2020 at 13:48

1 Answer 1


I too downloaded the new version and there is no more apply button. Instead, there is a drop down next to the camera icon and you can select apply or press Ctrl + A it seems.

I was able to separate pets in edit mode then.


Not the answer you're looking for? Browse other questions tagged .