0
$\begingroup$

I have a scene and I'd like to render out PNG layers to make life easier in post-production. I have set up all my layers to render separately. However, Blender is also spending time rendering out a composite of all layers even though I only have the following node setup:

enter image description here

Note that there is no composite setup, but I still get one. It's adding a lot of extra time to my render.

Thanks for your attention.

$\endgroup$
8
  • $\begingroup$ Does this help ? blender.stackexchange.com/a/155633/86891 $\endgroup$
    – Gorgious
    Oct 19, 2020 at 7:14
  • $\begingroup$ In the nodes you are showing, you are saving the composite pass, not any other render pass (like diffuse, normals. or other). And if you are looking to "make your life easier" in post production avoid png, use OpenExr Multilayer. $\endgroup$
    – susu
    Oct 19, 2020 at 14:11
  • 2
    $\begingroup$ Does this answer your question? Save all render passes to EXR image? $\endgroup$
    – susu
    Oct 19, 2020 at 14:11
  • $\begingroup$ @Gorgious - If my read on that first link is correct, then I need to uncheck Render Single Layer, correct? $\endgroup$ Oct 19, 2020 at 14:59
  • 1
    $\begingroup$ PNG is not a format to transport linear information (which is what you should use for compositing). Plus PNG is not capable of using associated alpha channel $\endgroup$
    – susu
    Oct 19, 2020 at 15:24

1 Answer 1

3
$\begingroup$

Okay, I figured out the answer:

Under RENDER and VIEW LAYER, make sure that Use for Render is UNCHECKED. This will eliminate that particular layer. In the compositor, plug in the the layers that you want to export per my initial graphic. Or, select the checkbox for Render Single Layer (while making sure you are actually on that layer).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .