0
$\begingroup$

I have read a lot of treads with the same problem. And I think I have tried to make everything. But Can't still get it to work. I'm new to Blender.

Working in Blender 2.90.1

I have made a character and pressed Ctrl + J. So it's only one mesh. Added the Armature Parented with auto weight so the Armature is pareting the Mesh. And when I go in to Pose-mode and click on a armature och moves it, the mesh don't follow.

Blendfile: https://easyupload.io/ofledn

What am I doing wrong?

$\endgroup$
1
$\begingroup$

I don't know how you did the parenting thing, but your problem is fixed if you select the mesh, go to Properties > Relations and change the parent type from object to Armature.

enter image description here

Re-parenting everything all over again, it works fine! enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Also, I noticed that the lower spine doesn't move with the respective bones, even after the fix, even though the arm works ok. You might want to re-parent the mesh to the armature all over again! $\endgroup$ – CBarr Oct 17 at 22:56
  • $\begingroup$ Thank you! I don't know why it did that. :O Next problem. :P I now made a new Armature and made it work with that. But some parts seams like they are stuck and don't move. Like the head. When I move the armature for the head only the "hair" is moving. How is that? Thank you for your patience! easyupload.io/v0f54c $\endgroup$ – Capta1nN3mo Oct 17 at 23:08
  • $\begingroup$ That just means that some portions of the mesh weren't assigned to any bones, so they're stuck. But I couldn't understand why, so I just cleared all of the parenting on your mesh (there were two Armature modifiers at the same time, for some reason!) then selected the mesh, shift-click on the armature, then hit ctrl-P and Armature Deform with Auto Weights, and it works perfectly. Obviously, the weight can be fine-tuned in weight paint mode, but it works pretty well on default. I dunno what you're doing different! (see new screenshot added to my answer) $\endgroup$ – CBarr Oct 18 at 1:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.