1
$\begingroup$

Blender Version 2.90.1 (2.90.1 2020-09-23)

I have made a very simple Tilt Brush drawing on Oculus Quest 2. I have exported it to Poly from Tilt Brush. In Poly I have published the sketch in private mode. I am then fetching a link to it via the Poly API, and download a GLTF fil (https://poly.googleapis.com/downloads/fp/1602791954433581/7xSV2Yv6hW6/6eSd6Co6PZC/sketch.gltf). When I try to import that file (standard import settings), I get the following error from Blender:

    File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 46, in from_union
    return f(x)
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 1162, in <lambda>
    accessors = from_union([lambda x: from_list(Accessor.from_dict, x), from_none], obj.get("accessors"))
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 70, in from_list
    assert isinstance(x, list)
08:11:20 | ERROR: An error occurred on line 46 in statement return f(x)
08:11:20 | ERROR: An error occurred on line 1162 in statement accessors = from_union([lambda x: from_list(Accessor.from_dict, x), from_none], obj.get("accessors"))
08:11:20 | ERROR: An error occurred on line 70 in statement assert isinstance(x, list)
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 46, in from_union
    return f(x)
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 38, in from_none
    assert x is None
08:11:20 | ERROR: An error occurred on line 46 in statement return f(x)
08:11:20 | ERROR: An error occurred on line 38 in statement assert x is None
Traceback (most recent call last):
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/__init__.py", line 928, in execute
    return self.import_gltf2(context)
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/__init__.py", line 942, in import_gltf2
    if self.unit_import(path, import_settings) == {'FINISHED'}:
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/__init__.py", line 955, in unit_import
    success, txt = self.gltf_importer.read()
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/imp/gltf2_io_gltf.py", line 164, in read
    self.data = gltf_from_dict(json.loads(content, parse_constant=glTFImporter.bad_json_value))
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 1218, in gltf_from_dict
    return Gltf.from_dict(s)
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 1162, in from_dict
    accessors = from_union([lambda x: from_list(Accessor.from_dict, x), from_none], obj.get("accessors"))
  File "/Applications/Blender.app/Contents/Resources/2.90/scripts/addons/io_scene_gltf2/io/com/gltf2_io.py", line 56, in from_union
    assert False
AssertionError
$\endgroup$
1
$\begingroup$

It looks like the problem is, that Poly exports GLTF v1.0, which is unsupported by Blender and others (ThreeJS, Chronos Blender GLTF Importer)

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.