0
$\begingroup$

I am rendering a scene that I have been working on for days. It has not a lot of detail, just a few not complex materials. It rendered in EEVEE fine with 1.1s per frame. I just changed some animations and scaled some objects but did not edit rendering settings.

Suddenly EEVEE is taking forever to initialize the render as well as to close it and open the next frame. When it actually renders, it takes only a second to render.

Is there any way to profile the rendering process?

I would like to try to find out:
What data containers where loaded,
how long did what process take
Where there any internal errors that are not shown in console
Are there maybe sudden driver issues

I have had this problem three times now on different scenes. It happens randomly but sticks with the file no matter what I do.

My System info:

64GB Ram
2x Nvidia RTX 2070 blower edition
AMD Ryzen CPU

$\endgroup$
3
  • 1
    $\begingroup$ You can start blender from command line with blender --debug-all or blender --factory-startup --debug-all See the manual $\endgroup$ – Timaroberts Oct 15 '20 at 21:55
  • $\begingroup$ Isn't it just the driver initialization? It should do it only once. I noticed this behavior once in a while but not often - maybe every time i update blender to a new version... $\endgroup$ – AFE-GmdG Oct 16 '20 at 9:05
  • $\begingroup$ Hey, i was not able to fully replicate the issue. I have re-build the entire scene exactly with the same topology. Randomly it occours and then stays. BUT I was able to fix it (not really a fix when you just re-do everything) by re-linking every single texture and material. I think it has something to do with the render cache. I think "normally" blender would load the required textures into gpu memory / ram once and from there adress it per frame. I guess what happens is, that blender is re-caching all files every frame. $\endgroup$ – Avion32 Oct 20 '20 at 9:44
0
$\begingroup$

I had the same issue yesterday, when trying to render scene from animation in EEVE. It took about 25 second for it to start. It was the same with Cycles and Workbench render. There's no automatic update on blender so in my case it could be Windows or GPU driver issue. Tried previous blender release, same thing happended

$\endgroup$
1
  • $\begingroup$ Hi @PeterSmith, i tried the same scene on a different machine: A Gigabyte AERO Notebook RTX 2070, 64GB Ram with studio drivers from NVIDIA. I the issue remained. Either it is Windows not working well with Blender to cache the files or something else. It is not the scene load itself as the scene works fine and renders in seconds per frame in EEVEE when I re-linked all files. But the isses randomly re-appears and then sticks until I re-link all geometry, files and materials. $\endgroup$ – Avion32 Oct 20 '20 at 9:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.