0
$\begingroup$

So I recently modeled a rabbit character and joined all the different pieces (like the eyes, arms, legs, etc.) and then rigged it, following this tutorial.

When I finished rigging, I went into pose mode and rotated the top bone. But the eyes, blush, and left ear didn't move with it. Only the face and the right ear rotated, as shown in the second picture below.

I have searched this up and read this question, but nothing helped. Here are some screenshots of my project:

Picture 1: Rigged character in the t-pose

T-Pose

Picture 2: Rotating the bone

Facial Features not Moving with Face

Picture 3: Rotating the spine (Front View)

Front View

Picture 4: Rotating the spine (Side View)

Side View

Note: Picture three and four are rotated differently so you can see the eyes blush, and nose aren't moving with it.

I was wondering if I had to do some weight painting?

$\endgroup$
  • $\begingroup$ Are ears and jowls separated meshes? Or if not are they weighted to any bone? And yes if they are not, you should weight paint (or weight directly) them. $\endgroup$ – lemon Oct 17 at 9:38
  • $\begingroup$ No they're one single mesh, because I joined them together. But how do I weight paint? I can only weight paint on the Nork mesh. Unless that's where you weight paint. $\endgroup$ – Wolfizzy Oct 17 at 9:45
1
$\begingroup$

When you create your rig and set it as the parent of your model, you have to choose, how the weight for the bones are created. This determines, what parts of your model are affected by which bone.

If your model is one object with several parts, all you need to do is to add all the parts you want to be affected to the vertex group. You can find that under Properties -> Object Data Properties -> Vertex Groups. You can either go to edit mode and set all the verticies you want to be affected as part of the vertec gropu coresponding to your bone, or you can go to Wight paint mode and do int there. In weight paint mode, you can also see the poses. For more complex models you would use weight paint mode, but for your model, i think manualy adding all the verticies in edit mode might work fine.

If your model is split into several objects, you need to set the armature as parent for each object. Then you can adjust the vertex groups and weights the same way.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Hey @aky-her, thanks for the solution. Where is Properties -> Object Data Properties -> Vertex Groups? I can't seem to find that in the top panel or anywhere. $\endgroup$ – Wolfizzy Oct 17 at 10:22
  • 1
    $\begingroup$ properties is one of the many panel types. If you did not change your layout, it is the one on the right, where you add modifiers, change render settings etc. Object Data Properties is the tab with green triangle on it (at least in the version of blender I am currently using) $\endgroup$ – aky-her Oct 17 at 10:23
  • $\begingroup$ Is this the one? Blender Properties IMG $\endgroup$ – Wolfizzy Oct 17 at 10:29
  • $\begingroup$ yes, you can see the list of all the vertex groups there. $\endgroup$ – aky-her Oct 17 at 10:30
  • $\begingroup$ Okay...so do I weight paint the left ear, eyes, etc. all red? Or I just add more vertices in Edit Mode? Could you elaborate more please? $\endgroup$ – Wolfizzy Oct 17 at 10:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.