1
$\begingroup$

I downloaded this tree model to study by myself.
But there is a black square around the leave and the flowers.

these are the flowers with black square

The node setup is here enter image description here

When I make the tree with the tutorial, there is only one image texture box(left yellow box) like the below picture. so adding transparent BSDF & Mix shader makes the leave clear.

enter image description here

this is the tree that I make following the tutorial;l

the first picture that I download has three image texture boxes in node, so it seems that it needs another solution for them to be transparent. is there any way that I can make it transparent??!

$\endgroup$
3
  • 3
    $\begingroup$ In the first screenshot, you're not using alpha from the texture, but color. $\endgroup$ – lemon Oct 14 '20 at 7:11
  • $\begingroup$ yes, this is the original one that I download. do you know what to change for transparency?? I changed the original node (second picture) with 'transparent BSDF & Mix shader' but it didn't work.. $\endgroup$ – gkr gb Oct 14 '20 at 10:29
  • $\begingroup$ + thank you for your reply! $\endgroup$ – gkr gb Oct 14 '20 at 11:25
0
$\begingroup$

Not sure, if you using Cycles or Eevee... But at least in Eevee you have to enable alpha for the leaf material in the settings.

Alpha Blend / Alpha Hashed

$\endgroup$
1
  • $\begingroup$ thank you!!! It did work!! Thank you so much! $\endgroup$ – gkr gb Oct 14 '20 at 11:15
0
$\begingroup$

can I ask another question?

1> there is a noise in the flower, unlike the leave? do you know why?

enter image description here

2> the right yellow box is the window of my tree modeling. there is no option for blend mode. can you tell me why there is a blend mode option in the left window, but not in the right one? enter image description here

And thank you again! I've been looking for the solution for two days and you saved my time!! thank you so much!

$\endgroup$
1
  • $\begingroup$ Don't use the answers section to ask questions or to comment. $\endgroup$ – no-can-do Oct 16 '20 at 1:56
0
$\begingroup$

Hashed means, that a pixel is either be 100% opaque or 100% transparent. The less Render samples of the Eevee scene sampling settings, the more this noise is visible. I think if you increase the samples the render is done multiple times with really slightly other angles and the results are mixed together.

You could reduce the Noise by increasing the Eevee render samples. Also enable soft shadows and increase the cube size. Set the shadow mode of the material to alpha hashed as well.

enter image description hereenter image description here

You could see the differences in this example:

enter image description here enter image description here

I add my sample to google drive: Alpha Hashed.blend

Sadly I did not know the answer of the second question without get a look at the blend file itself.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.