1
$\begingroup$

I'm trying to texture paint a character in Blender, and I am loosely following a tutorial, just so I know what I'm doing. So this is what I've done:

  1. Went to the Texture Paint tab.

  2. Created a new material (on my character) and then in Base Color, clicked on the dot on the right side and then clicked Image Texture. I then created a new texture with the size of 2048px.

  3. In Object Mode, I clicked on the Shading arrow on the right, near all the viewport shading buttons, and then clicked Flat.

  4. (This was either step 3 or 4,) but I saved the texture and placed it near my .blend file.

That's where I stopped, because it gave me the warning. This is the current screenshot of what the editor looks right now:

Blender Warning.

I've searched on the net already, and saw this article, but the suggestions weren't really helpful.

Also in the same question, I was wondering how the person got this:

Unwrap

Menu to show, as the GIF was to fast for me to catch it.

Also I have seen these questions:

  1. I am not able to use texture paint (2.8)
  2. missing files blender 2.82 Missing UVs, Textures, detected!

But none of those worked. In the question number 2, I did try to change mode to Single Image, but nothing worked.

In Mode

Maybe I'm changing it in the wrong place?

$\endgroup$
0
2
$\begingroup$

I've finally fixed the problem in the answer to this question. I needed to click Add UVs and then upload the (blank) texture I had.

In the tool bar, I clicked Draw and then it gave me the options to paint the character.

However, I had another problem, which is that when I try to paint my character, the paint did not show. I fixed it by this answer.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.