2
$\begingroup$

I'm having a problem where the lights on my car (and the area lamp) are flickering when i play the animation. I used a cube with the principled volume settings and the flickering is only caused when this cube is active. I tried messing around with both the Volumetrics settings in the Render properties as in the Principled Volume shader.

It looks like the cones of light are flickering whenever the volumetric cube is active. Does anyone know how to fix this issue?

I've added a video of how it looks and my settings.

Thanks in advance, Alex

Video of render example: Video of Render Example

Settings

Settings

Settings

Settings

$\endgroup$
1
  • $\begingroup$ Of course too late, but I solve this problem by reducing the spot radius back to 0.25m. I don't know why but good to know! $\endgroup$
    – loopkin
    May 10 at 0:19
0
$\begingroup$

Seems like Eevee sometimes really has some troubles with volumetric lighting. As they say here: https://developer.blender.org/T71208

I think this was a side effect of a previous bug (in 2.80). basically, the volumes were all shifted 1 voxel further from the camera. This was fixed but now this light leaking is just a side effect of the volume texture being low res. There is little we can do to fix it. The workaround is to give more precision to the volume (increase samples in volumetric settings) and the shadow maps.

this is a sort of precision error. This probably won't be fixed anytime soon. Unless a new groundbreaking volumetric lighting approach is discovered, which is... quite unlikely? You can attempt to alleviate this by making the volumetric lighting texture more fine. This will however use more VRAM so be careful

I hope it will help.

These few quite similar cases may be helpful too:

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.