1
$\begingroup$

Ive tried many of the fixes ....but am still unable to solve this....im using 2.90.1 version and this has been happening to me since 2.83.

solutions ive tried:

  • applying scale and rotation
  • turning on use modifier stack in emission settings(solution found on stack exchange)

this is what happens when i add a particle hair system to any object

blend file download

particle settings

viewport

another project with same error

another project with same error

viewport of alernate project

Viewport of alternate project

enter image description here

hair is visible in wireframe mode

$\endgroup$
9
  • $\begingroup$ That Blend file access is locked so no one can view it! $\endgroup$
    – John Eason
    Commented Oct 10, 2020 at 11:20
  • $\begingroup$ @JohnEason ive updated the link do check it ... $\endgroup$ Commented Oct 10, 2020 at 17:26
  • $\begingroup$ Hi and welcome :) Please use Blend-Exchange for uploading blend files, also please be specific as to what you have done to fix your problem, and clearly describe it for other users. Images of particle settings, the entire viewport, ect, are helpful. :) thanks $\endgroup$
    – Timaroberts
    Commented Oct 10, 2020 at 17:28
  • $\begingroup$ @Timaroberts thank you so much....i will edit and put everything in detail in my question $\endgroup$ Commented Oct 11, 2020 at 4:39
  • $\begingroup$ Used your blend file. In my Blender 2.90.0 everything looks fine. All thair is emitted from the cube with the subsurf modifier. Maybe an addon messes up something? $\endgroup$
    – Blunder
    Commented Oct 18, 2020 at 15:30

2 Answers 2

0
$\begingroup$

Just had the same problem. I've joined 2 objects (one with a modifier) and separated the meshes again into two objects. This copied a Bevel modifier on the object. The modifier caused the particle origin problem.

Either remove the modifier or tick the checkbox Use Modifier Stack in EmissionSourceEmit from. This solved the issue and the particles are emitted from faces again.

$\endgroup$
5
  • $\begingroup$ thanx for the reply mate but im having this error in every single blend file.....So im probably gonna reinstall blender and hopefully that does it $\endgroup$ Commented Oct 19, 2020 at 20:12
  • $\begingroup$ reinstalled blender its still doing the same thing....btw the hair is visible in the correct spot in wireframe mode and even in a render but not in solid mode $\endgroup$ Commented Oct 19, 2020 at 20:22
  • $\begingroup$ @RohithEyyani do you have addons installed that could cause this problem? Blender's preferences and addons are stored in the user directory and might be not affected by a re-install of Blender. $\endgroup$
    – Blunder
    Commented Oct 20, 2020 at 0:46
  • $\begingroup$ its solved now it was cuz of some addon .....hair tool or hairTG...now that ive disabled it its fine....its working now.....thanx mate for the help $\endgroup$ Commented Oct 20, 2020 at 3:37
  • $\begingroup$ @RohithEyyani Happy to here you solve it, but ...Why did you marked the answer as solution for you, when your issue was an addon? $\endgroup$
    – vklidu
    Commented Oct 20, 2020 at 6:41
0
$\begingroup$

Hello everyone I just started using blender And i encountered this problem. I downloaded the human model from sketchfab and I do not think I have any hair add on installed. Please can someone hep me out.

$\endgroup$
1
  • $\begingroup$ This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. To get notified when this question gets new answers, you can follow this question. Once you have enough reputation, you can also add a bounty to draw more attention to this question. - From Review $\endgroup$
    – Ron Jensen
    Commented Nov 2, 2021 at 13:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .