0
$\begingroup$

I wanted to weight paint the grass and when I noticed I couldn't paint I switched to viewport and saw this. Render still looks fine. Not working in 2.83 either, hoping I just accidentally activated some stupid setting. Recalculating and flipping normals didn't work either

EDIT: my description was very vague so here we go again, my problem is that I see the back part of the model instead of the front (if that makes sense). Viewport

Render

$\endgroup$
4
  • $\begingroup$ You have 'Random' selected under Color instead of 'Material' on the Viewport shading dropdown. $\endgroup$
    – John Eason
    Oct 9, 2020 at 18:00
  • $\begingroup$ that's not my problem, it's that I see the back of the model instead of the front. My bad, described it very vague $\endgroup$
    – Kennock
    Oct 9, 2020 at 18:06
  • $\begingroup$ I had the same problems a few weeks ago. Unfortunately, I can't remember how I solved it. If I just remember I will post it. $\endgroup$
    – LeoNas
    Oct 9, 2020 at 18:57
  • $\begingroup$ Not your fault. I didn't look closely enough! Sorry I can't help with that one. $\endgroup$
    – John Eason
    Oct 9, 2020 at 21:01

1 Answer 1

1
$\begingroup$

[FIX as of jan 2021] after having this problem again I was able to pinpoint the Problem to be only in orthogrraphic view, the fix for this was then changing the clip end, I've also read that changing the clip start can also fix this

[FIX as of 2020] I have no clue why but here's how I fixed this.

  1. Go into Material preview (press z in the viewport)
  2. Press the Arrow in the top right corner and activated these two settings settings
  1. Deactivate them again and it worked for me. The problem was probably just that the viewport had an error and just needed to update the lighting, which is what this did. Hope this helps anyone in the future
$\endgroup$
1
  • 1
    $\begingroup$ Great you solved it, but this is not how it should work, so if you are able to reproduce issue with a new blend, post it as a bug report. Thank you. $\endgroup$
    – vklidu
    Nov 10, 2020 at 6:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .