0
$\begingroup$

I got blender into a somewhat strange state after I decided to add some vertex colours to my sculpt for better visibility.

As I load the save file I cannot paint the face sets anymore, not can I paint the mask. 'Invert mask' would do nothing.

Creating a new mesh and trying to sculpt it won't work.

Effectively, I'm forced to go back to my older save, or copy everything to a new document.

I think the only things I did to get here was:

  • set up the vertex paint material
  • tinker with the viewport display to show vertex colours
  • actually paint some over the mesh

Any advice on how can I force the document back into an usable state?

Note 1: Here's the blend file featuring the problem.

Note 2: The overlays are indeed enabled.

$\endgroup$
0
$\begingroup$

The problem is the Armature. Modifiers prevent Hide, Mask, and Facesets in Sculpt mode. Usually, you get a warning like this:

Warning active modifiers in sculpt mode

Armature, Cloth, and Hair/Particles, and all the other physics are also Modifiers. It's probably a bug that Blender doesn't warn you if you have one of these 3 activated. (Dynamic Paint gives you a warning.)

To see your Facesets and Mask in Sculpt Mode again you just have to disable the Armature modifier in viewport render by clicking the little icon that looks like a monitor.

Sculpt mode with disabled modifiers

Make sure your Faceset overlays are enabled. It's not enabled in the uploaded blend file ;-)

$\endgroup$
1
  • $\begingroup$ Thank you so much for helping me out on this! It was driving me crazy that after copying everything to anew blend file I managed to eventually (by adding the rig) break it there as well. $\endgroup$ – Shinyuu Oct 10 '20 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.