1
$\begingroup$

I've started modelling my first car ever just for practice on Blender. I modelled the rims (maybe not the best topology but for now I think it's almost good.)

Now I need to model the flat circled faces where the bolts are fixed, for that purpose I've choose to use a boolean with an array of a cylinder, but with a smooth shader I have the problem of weird shades, I know that it's caused by cylinder's faces that doesn't match the convex mesh of the rim but I've tried to fixed it without any success.

I've tried to use a boolean with an UV sphere with alot amount of faces and rings but even if the shades are smaller they're still there, I've tried to add more loop cuts but the problem persist and the convex face is not smooth anymore.

It's three days that I'm on it and I don't know how to do that, in C4D I use boolean with no problems why in Blender if you don't have a perfect topology you have all this problems? I'm using blender 2.9 on a new mac book pro 16'' enter image description hereenter image description hereenter image description here

$\endgroup$
2
  • $\begingroup$ Hey, nice rims :). If only shading is the issue, you can simply shade the faces as flat. But proper topology will save you a lot of time going forward. $\endgroup$ Oct 7 '20 at 11:06
  • $\begingroup$ There may be some ways to get the boolean operation to not look terrible when shaded but as Jachym says, the best way to go about this is by modeling the holes in manually. This will give you much better topology and cause less issues down the road. This and this guide may be helpful. $\endgroup$
    – PGmath
    Mar 29 at 12:35
2
$\begingroup$

You can also try the Edge Split modifier.

Note the messy looking edges

Edge Split modifier

Now looking nice!

$\endgroup$
1
$\begingroup$

Ok here we are, I've fixed all by improving the topology. So basically I recalculated the number of edges for matching it with the faces on the surfaceenter image description here

Then I erased the faces and made a bridge edge loopenter image description here

Added and applied a warp modifier with sphere falloutenter image description here

Added a loopcut to fix those nasty shades and joined this part with my rim and made a bridge edge loop to link his edges togheterenter image description here

Now it's ok but what if I needed to keep those edges smoother?enter image description here

$\endgroup$
0
$\begingroup$

Have you tried to switch on the Auto Smooth option for Normals on the rims? It prevents artifacts that can occur when the Boolean modifier is used on curved surfaces. Depending on your geometry you have to adjust the angle value (default is 30d) or add a few more edge loops. (Looks like you have only 2 rings but many edges for the "walls" of the sphere.) Autosmooth normals off/on

$\endgroup$
1
  • $\begingroup$ Yes I've tried but I didn't find the correct value to prevent that flat also the parts that I want keep smooth $\endgroup$
    – GGKMNTN
    Oct 7 '20 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.