5
$\begingroup$

enter image description here

enter image description here

I am finding that at certain spots in my mesh, when I've applied subsurf modifier, I get these weirdly sharpened / extended edges on some joins, but not on others. See the photos for what I mean.

I've tried playing around with adding edges and loop cuts but that doesn't seem to fix the issue.

Here's another example of this, may be a different problem, but this was seems to actually be making creases of some sort.

enter image description here

Blend file is here: http://www.pasteall.org/blend/33247 Any help much appreciated, Thanks!

$\endgroup$
7
$\begingroup$

The artifacts you are talking about are results of a bad topology of your mesh. The subdivision modifier is very sensitive to your edge, vertex and loops placement. The mesh should be ideally all square faces (no triangles or ngons) and have similarly sized polygons around creases.

There is a lot on the internet about mesh topologies (examples etc.), search for "mesh topology" or "mesh edge flow". Here are some tutorials from CGcookie.

In your model you can start by removing ngons, having all quads, and spacing even edge-loops around your creases:

mesh topology

$\endgroup$
  • $\begingroup$ Thanks, this did the trick. Mostly getting rid of a couple of those Ngons and having more evenly spaced out ring cuts near creases. $\endgroup$ – Phil Dec 9 '14 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.