the problem

I want the robot arm to always be fully visible in front when rendered (and preferably while working in the viewport, too). So the tree should never overlap the robot in the final image, even if the robot is technically inside the tree.

How can I achieve this (in the easiest way possible)?


1 Answer 1


Create two scenes, one with the tree only and the other with the robot only. enter image description here

The robot scene should have a transparent background (Select Film Transparent in the Rendering Properties menu). enter image description here

In the Compositor mix the two scenes using the alpha of the robot scene as mix factor. enter image description here

  • 2
    $\begingroup$ I think using view layers in the one scene rather than two different scenes would be more convenient in this case : That way you can actually see and edit the interactions in real time if you create a third view layer with all objects enabled. Just my 2 cents $\endgroup$
    – Gorgious
    Commented Oct 6, 2020 at 9:05
  • $\begingroup$ Yep... Actually you're right. But I haven't used layers in 2.8 and later yet, so I answered with something I was sure about. :-) $\endgroup$
    – mugnozzo
    Commented Oct 6, 2020 at 9:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .