14
$\begingroup$

I have a rig, and when I select the Armature or the Model, and go to edit mode, they move position. They just go to the left, and they come back in object mode.

$\endgroup$
1
  • $\begingroup$ If you upload your Blend we could take a look at it: pasteall.org/blend $\endgroup$
    – Humilton
    Commented Dec 8, 2014 at 14:22

11 Answers 11

18
$\begingroup$

enter image description here

In Pose mode make sure you are in "Pose position" .

In rest position it will go to the objects original position and origin point

Also , Edit mode doesn't effect the animation / Pose , so when you go into edit mode , the armature will also go to the objects original position and origin point . Edit mode is only for moving vertices/faces/edges and bone origin placement

$\endgroup$
3
  • 1
    $\begingroup$ yay , first time someone i've got a tick :D $\endgroup$ Commented Dec 9, 2014 at 3:43
  • $\begingroup$ Well, you deserved the big ole' green check button. $\endgroup$
    – blackhole
    Commented Dec 10, 2014 at 21:04
  • 3
    $\begingroup$ Is there a way to change the rest position to be what the pose position is? $\endgroup$ Commented Sep 2, 2019 at 18:16
7
$\begingroup$

I had this same problem too! I tried all of these answers but none helped, I finally figured it out. All you have to do is go into pose mode and select each bone individually(you might be able to select all but I didn't try) and press "Ctrl+A" and apply location, rotation, and scale. If this doesn't help for you I am very sorry. It worked for me.

$\endgroup$
4
  • $\begingroup$ This worked for me! $\endgroup$ Commented Aug 11, 2018 at 2:12
  • $\begingroup$ This also worked for me, thanks! $\endgroup$ Commented Oct 26, 2021 at 3:25
  • $\begingroup$ Great answer, thank you $\endgroup$
    – Georges D
    Commented Dec 2, 2021 at 20:44
  • $\begingroup$ the entire armature's pose can be converted to its edited positioning by selecting all bones in pose mode, press CTRL+A, and select "apply pose (selected) as rest pose". Now the pose is set for all editing modes. $\endgroup$ Commented Dec 16, 2021 at 10:54
2
$\begingroup$

"Clear Transform" in Pose Mode helps to reset the bones transforms to the "Pose Position" in Edit Mode.
It clears any Pose Mode transforms and resets the armature to the Pose Position.

Steps
1 Edit Mode -> .Select entire armature (works even by selecting only the transformed bones)
2 Pose Mode goto -> Pose ->Clear Transform -> All

enter image description here

$\endgroup$
1
  • $\begingroup$ This is what it was for me, yes. Thank you. $\endgroup$
    – Robinson
    Commented Feb 19 at 12:05
2
$\begingroup$

In my case here is the solution.

I recorded motion capture using IPI soft, and the armature position was different in edit mode and pose mode.

Here is how I fixed it.

  1. Find the bone which moves the whole armature. In my case or normally it's Hip bone that moves the whole armature.

  2. Select the armature in object mode and go to pose mode, after this, select this Hip bone/Main bone, which moves the whole armature.

  3. Open the Dope Sheet and select Action Editor, and below you will see all Locations keyframes. Example,

    X Location (Hip) = keyframes

Y Location (Hip) = keyframes (In my case removing the Y location keyframes worked, because it's was the only keyframe, that was changing my armature location)

Z Location (Hip) = keyframes
  1. After removing the Location keyframes, now select the whole armature and in pose > Clear Transform > All.

  2. Go to object mode and play animation :)

That's it.

$\endgroup$
1
  • $\begingroup$ Another approach is to set the bounding box of the character to the world origin, (assuming T-pose and character stature is similar) and then apply auto weights. Seems like EDIT mode aligns hip bone to world origin, whereas OBJECT and POSE modes align to "ground plane". $\endgroup$ Commented Feb 28, 2023 at 21:33
1
$\begingroup$

Unless it's some really weird placement, then what you describe is how it's supposed to be =) What you see in edit mode are the default positions of your bones. In other words, where your bones will be if you reset the position/rotation/scale in pose mode.

$\endgroup$
3
  • 2
    $\begingroup$ "....in pose mode;" this happens when I go to object mode not pose mode. $\endgroup$
    – blackhole
    Commented Dec 7, 2014 at 23:01
  • 1
    $\begingroup$ What you do in pose mode determines what happens in object mode. Object mode shows the same as pose mode. $\endgroup$
    – Humilton
    Commented Dec 7, 2014 at 23:27
  • $\begingroup$ Do your pose mode and your object mode show different bone positions? $\endgroup$
    – Humilton
    Commented Dec 7, 2014 at 23:28
1
$\begingroup$

In Pose Mode select all bones, Right Click and choose Clear user transforms, the very bottom option.

$\endgroup$
0
$\begingroup$

Apply all the modifiers, which you have, such as subdivision surface, solidify etc.

Then do the "With automatic weights" all bones will be in the correct places.

$\endgroup$
0
$\begingroup$

I think it is simple sir please click on the armature and then find Reset Position and then click on that.

While you pose again click on pose position.

$\endgroup$
0
$\begingroup$

You may loose all animation and have trouble reapplying actions (newly applied actions will be relative to the OLD rest position), but if your Pose Mode is a T-Pose, Select->All in Pose Mode and go to Pose -> Apply -> "Apply Pose as Rest Pose". Then both your Rest Position and pose in Edit Mode should that be exactly the same as your T-Pose.

I believe this gives you the ability (or forces you) to redo your animations with a rig whose Rest and edit mode matches the T-Pose.

$\endgroup$
0
$\begingroup$

Try selecting your armature, go to armature settings on the right click on rest position and then after when it teleports to its rest position. put it to pose position it should reset.

$\endgroup$
0
$\begingroup$

I was facing the same problem. I tried something. first, go to edit mode, and remove the parent from the armature, then start posing the bone to relate to the mesh in edit mode, when done, start parenting every object to the armature in object mode. my armature was moving its location from object mode to editing mode, and that was annoying. I removed it, parent, in object mode and I noticed that the mesh is taking the location, scale, rotation of the armature whenever parenting it. so when we make its location etc. matches the location etc of the mesh. Both mesh and armature location must not change in both modes (object and editing mode). so that's what I came up with to solve my problem. hope that helps.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .