1
$\begingroup$

To reproduce:

  • Download DAE
  • Open in Blender
  • Export to glTF (default settings)
  • Open exported glTF in Blender
  • Click on mesh
  • Go into edit mode
  • See that it is rotated 90 degrees around the X axis
$\endgroup$
5
  • $\begingroup$ What Blender version? Doesn't happen for me with 2.91. $\endgroup$
    – scurest
    Oct 4, 2020 at 15:52
  • $\begingroup$ I'm running 2.82, I can try updating $\endgroup$
    – Shasaur
    Oct 4, 2020 at 16:04
  • $\begingroup$ glTF importer's skinning improved significantly in 2.83. $\endgroup$
    – scurest
    Oct 4, 2020 at 16:07
  • 1
    $\begingroup$ Ah, yeah I just tried updating and it looks fixed. Thanks so much for pointing this out! $\endgroup$
    – Shasaur
    Oct 4, 2020 at 16:15
  • $\begingroup$ You can leave it as a comment and I'll accept it as the answer @scurest $\endgroup$
    – Shasaur
    Oct 4, 2020 at 16:15

1 Answer 1

2
$\begingroup$

The solution was to upgrade Blender from 2.82. 2.83 had big improvements in skinning for the glTF importer.

By the way, if you ever have issues with how a skinned mesh looks in edit mode, you can also try toggling the "Guess Original Bind Pose" option on the glTF import screen.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.