2
$\begingroup$

Hello everyone, I'm having this problem: The more pixels being render, the worse screen space reflection outcome, also in contradict, the less pixels being render, the better the reflection.

It's actually not like better or worse though, looks like the reflection just disappear. Look at the ground of the 1000px version vs 3000px version, the reflection of the roof where the lights is being placed just simply disappears, and the reflection on the other parts disappear as well but the picture I'm having for you here is too poor quality to be analyzed further. Also if the render had even less pixels to be rendered (below 1000px for example), then it will have even better reflection than the 1000px version itself. And if it got more pixels to be rendered, reflections will gradually disappear.

Please help me solve this problem. It's a important project for my class. Any help is greatly appreciated! Thank you.

[EDIT] PROLEM SOLVED:

  • NEVER NEVER set the trace precision to the max (1000) as it will cause reflection errors like this. 0.999 works great, as long as not the maximum setting.
$\endgroup$
3
  • 1
    $\begingroup$ Some thoughts as to how to diagnose this... 1) Can you create a simplified test case that you can share with others or provide simple instructions as to how others can replicate it? 2) Is it a gradual difference or something sudden? eg, does 2500x2500 work and 2501x2501 not work or is it a gradual change as you move up the resolution? 3) What version(s) of Blender have you tried this on and do other versions produce the same result. $\endgroup$ Oct 2 '20 at 11:44
  • $\begingroup$ @RichSedman 1) I will try my best if I can make another simple scene as a test case in the next few hours. 2) Yes, it is a gradual difference, the reflection gradually disappears when increasing up the solution and gradually appears when decreasing the solution. It means at around 100x100px, the reflection will be seen more clearly and will disappear completely at around 10000x10000px. 3) I tried this on the 2.9 version. I don't want to use the previous versions as they lack of functions that the 2.9 have. $\endgroup$ Oct 2 '20 at 11:57
  • 2
    $\begingroup$ Glad you've identified the cause. Thanks for updating the question with your solution. Please add an answer (instead of an edit to the question) and you can then mark that as the accepted solution. This way the question doesn't remain 'Unanswered' and other people can more easily learn from your experience. $\endgroup$ Oct 2 '20 at 22:19
1
$\begingroup$

Solution to the problem: Don't set the Trace Precision to the maximum (1000) as it will cause reflection errors like this. The screen space reflection will work perfectly if set to be around 0.950 or lower.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.