1
$\begingroup$

I am working through a tutorial and modeling a couch. I'm at the stage where I have been sculpting in fabric details and wrinkles (I am not using Dyntopo). I've noticed that when I sculpt with anchored alphas, this weird checkerboard pixelated effect occasionally shows up that I can't get rid of. Smoothing doesn't remove it, and even when I add an extra 1-2 layers of subdivision it won't go away.

Here is a picture of my sculpt:


Checkerboard Artifacts

Here is an image of the cushion from the tutorial's file without the problem:


Tutorial No Artifacts

Here's the wireframe of both my mesh and the tutorial's mesh:


Both Wireframes

I thought at first that it was because I'm using a low quality stencil, but it's the same alpha that came with the tutorial.

I then thought the problem was that I didn't have enough geometry, but subdividing further doesn't solve the problem either (it helps, but minimally). Also, the tutorial's version of the same cushion has the exact same amount of subdivision / density.

Furthermore, I've noticed that the effect is exaggerated depending on the rotation of the alpha when placing the stroke.

Does anyone have any possible ideas as to what this is, and how to get rid of it?

Thanks much.

Edit: I've uploaded the .blend file for you all to look at. Both my mesh and the tutorial mesh are side by side in the scene. I've also updated the wireframe image to include both.

Edit2: Just added a +100 rep bounty to the question.

$\endgroup$
5
  • $\begingroup$ Have you Shade Smoothed? Also, maybe he gave his object a Subdivision Surface and you have not? Maybe share your file here: blend-exchange.giantcowfilms.com $\endgroup$ – moonboots Oct 1 '20 at 7:18
  • $\begingroup$ Yes, the entire mesh is smooth shaded. Like I said in the question, both meshes have the exact same level of subdivisions. I'll update the post now with the .blend. $\endgroup$ – Jay Oct 2 '20 at 20:48
  • $\begingroup$ maybe you need to work with the Autosmooth option at 1 (Brush Settings in the N panel)? $\endgroup$ – moonboots Oct 4 '20 at 4:37
  • $\begingroup$ Do you have a link for the tutorial? I want to investigate more. $\endgroup$ – cppBeginner Oct 13 '20 at 11:47
  • 1
    $\begingroup$ Yup, here you go: blendermarket.com/products/modeling-a-leather-couch-in-blender I finally finished it about 4 days ago and it came out great. Here's my final render: i.imgur.com/yTZRBE2.jpg $\endgroup$ – Jay Oct 14 '20 at 0:17
3
+100
$\begingroup$

This is just a half-answer.

Causes

As I looked closely into the difference of your meshes ... enter image description here

  1. Some of the wrinkle in your sculpting is more in the diagonal direction of the edge than the tutorial.

  2. Your brush seem to adjust only in Normal direction of the mesh, but tutorial brush seems to also pull nearby vertices close together to keep up with the deep detail.

Workarounds

There are 2 different approaches I can think of.

  1. This one is more of the macro level. I googled and found 2 links. (https://www.youtube.com/watch?v=vYzS94fPo1w, and https://www.youtube.com/watch?v=MLUnfE4FcOY)
    They use cloth simulation to (automatically) generate wrinkle and pull vertices to the location that needed. Thus the artifact become less.

  2. However, I believe the main problem is the sculpting brush type.
    The correct brushes should have pinch attribute e.g. pinch-brush itself (but has no add/subtract mode, sadly), or crease-brush.
    The pinch (search for the word in https://docs.blender.org/manual/en/2.82/sculpt_paint/sculpting/tools.html) means to will pull vertices together when sculpting.
    If there are enough vertices, just the crease-brush should be enough. (as I found in https://www.youtube.com/watch?v=vbUJVzBBlVY )

Here is the setting of crease-brush. Not every brush type has this pinch feature.

enter image description here

Here is my attempt to reduce the artifact. I used pinch-brush after normal sculpting. After the process, it is noticeable that the result become better. I didn't use crease-brush though.

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Thanks so much for your answer, that's definitely the core issue. In the tutorial the instructor was using the pinch and crease brushes for the sides of the pillow along with the anchored stencil brush. I skipped those brushes because I figured I could just do it with the stencil and be fine. I didn't realize his method was actually optimizing the underlying topology. Thanks again for taking such a detailed look at my issue. $\endgroup$ – Jay Oct 14 '20 at 0:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.